Filament sensor not shown by M119 command



  • Hi everyone, I need help to set up Filament sensor for my machine. I am using a normal limit switch for that shown in the image. I tried all of the settings which I found on the forum but no luck. I am using 2.05 firmware. These are the commands I tried. I change the wire orientation since it's on the wrong side on the opposite end. The red one I used to check whether the limit switch is ok or not.gjqhrm1429092388096.jpg Annotation 2020-01-21 121432.jpg Annotation 2020-01-21 122347.jpg

    ; Endstops
    M574 X1 Y1 Z0 E1 S0
    ; Filament runout sensor
    M591 D1 P1 C3

    M591 D0 P1 C3 S1

    M581 E1:2 S1 T2 C1

    M591 P3 C"e0_stop" S1

    M591 P3 C"e0_stop" S0

    All the commands show same result of not detecting the sensor



  • I'm quite confident that M119 will never ever report filament sensors.
    Does any of your M591 commands result in error messages?
    Whats the output of M122?

    To define a simple switch type filament sensor for extruder drive 0 connected to the E0 endstop input you should use something like

    M591 D0 P1 C"e0stop" S1
    (for RRF3.x)
    or
    M591 D0 P1 C3 S1
    (for RRF1.21 to 2.x)

    (if RRF reports filament out when filament is present you may need to change P1 to P2 in the above commands)


  • Moderator

    @Ambros Most of the answers are here: https://duet3d.dozuki.com/Wiki/Gcode#Section_M591_Configure_filament_sensing

    First, remove 'E1' from your M574 endstop configuration, it's not how you define a filament sensor and may be confusing the firmware, though should be ignored (support for this way of configuring endstops for extruders was dropped after RRF 1.16).

    Which extruder drive are you trying to monitor, D0 or D1? This will be defined by the tool in config.g. You should be able to check the filament sensor setting by sending M591 D0, assuming it's D0 you're trying to check. Sending this should tell you if filament is loaded:

    M591 D0
    Simple filament sensor on endstop 3, disabled, output high when no filament, filament present: no

    Your sensor looks like a standard microswitch, so should work with P1. If you get a message that there's no filament when there is filament loaded, try P2.

    In RRF 2.05, the 'Cnn' parameter is the endstop number, where:

    0=X endstop input, 1=Y endstop input, 2=Z endstop input, 3=E0 endstop input etc. If you have a Duex 2 or Duex 5 in your system, note that C5 thru C9 (the endstop inputs on the DueX) cannot be used for filament monitors, but C10 and C11 (the endstop inputs on the CONN_LCD connector) can.

    By setting S1, it will only check the sensor when printing from the SD card. Note that S0 is the default, which disables the filament monitor, so you need S1 in.

    M119 doesn't report filament monitoring status.

    So your command should probably be M591 D0 P1 C3 S1.

    Ian



  • @droftarts Thanks to both of you p2 worked for me.


Log in to reply