Manually extruding issues with new interface



  • Since upgrading to the new interface, I have not been able to manually retract or extrude filament. I've let both heaters come up to temp as well, but the options still remain grayed out. Am I overlooking something that has changed between the two interfaces? Thank you for any help!!

    Duet2.jpeg



  • Probably you need to select a tool , usually T0.


  • Moderator

    @flyscha from the image it looks like the tool is active, I think. So either the minimum temperature for extrusion has been set high with M302 https://duet3d.dozuki.com/Wiki/Gcode#Section_M302_Allow_cold_extrudes , or the tool is not configured correctly. Send M302 on its own to check the state, post response from console. If that doesn’t help, please post your config.g.

    Ian



  • Thank you for the replies!

    There was no M302 command anywhere in my config, so I used the link @droftarts provided to write that line. I'm still having the same result. Funny thing is, everything worked great in the original interface.

    Here is my config.g:

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Mar 31 2019 19:33:17 GMT-0700 (Mountain Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X32 Y32 Z32 E16 I0 ; Configure microstepping without interpolation
    M92 X322.00 Y322.00 Z1602.00 E215.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z25.00 E450.00 ; Set maximum instantaneous speed changes (mm/min)was 900,900,12,450
    M203 X12000.00 Y12000.00 Z4000.00 E800.00 ; Set maximum speeds (mm/min)E was 5000
    M201 X1200.00 Y1200.00 Z500.00 E500.00 ; Set accelerations (mm/s^2)was 600,600,250,250
    M906 X1800.00 Y1800.00 Z1400.00 E1700.00 I0 ; Set motor currents (mA) and motor idle factor in percent
    M84 S500 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X220 Y220 Z240 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z0 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M558 P5 I1 R0.35 X0 Y0 Z1 F650 T6500 H2 ; Set Z probe type to effector, the axes for which it is used and the dive height + speeds
    G31 X0 Y0 Z-0.100 P100 ; Set Z probe trigger value, offset and trigger height (more negative is further from the bed).
    M557 X4:210 Y10:210 S66.666666 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; Set temperature limit for heater 0 to 100C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P1 D0 H1 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C
    M302 S120 R110 ; Allow extrusion starting from 120°C and retractions already from 110°C

    ; Custom settings are not configured

    Thanks again for the help!


  • Moderator

    @flyscha What firmware are you running? Your config.g says "firmware version 1.17 to 1.19", though you may have updated it. If you're running old firmware with the latest DWC, that might cause issues. Send M115 and post the response. Which version DWC? If you left the files on the SD card, you can use the old DWC by pointing your browser to "[your-ip-address]/reprap.htm".

    I can't see anything obviously wrong with your tool setup. What happens if you send M302 P1, which should allow cold extrudes?

    Ian



  • @droftarts Here's that response:

    M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.04 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2019-11-01b1

    Duet Web Control 2.0.4

    Sending M302 P1 shows green as though it accepts the command, but the extrude & retract buttons are still grayed out.


  • Moderator

    @flyscha Hmm... can you run M98 P”config.g”. This will run the config.g and show any errors, that you don’t see at startup.

    Ian



  • @droftarts When I run that command, it says:

    HTTP is enabled on Port XX
    FTP is disabled
    TELNET is disabled

    Again, thanks for your continued help!



  • What happens if you send T0 P0 from console?
    Edit: I can see now you have your tool selected. I cannot see M584 in your config.g



  • @Ntrack T0 P0 code gives me a green box with a check mark to show it accepted the command, but nothing changes.

    You're right, there is no M584 in my config.



  • @flyscha You haven't defined a Tool 0 in your config.g - only a Tool 1. As you only seem to have 1 tool, then I suggest you define it as Tool 0 (numbering always starts at 0) or send T1 instead of T0 before you attempt to extrude. To be clear, in config.g replace M563 P1 D0 H1 with M563 P0 D0 H1.



  • @deckingman Replacing the P1 with P0 in the config file was the trick! Now the retract option is available immediately when I activate the hot end heater, and when it reaches 160c, the extrude option is now available. Hooray! Again, it's just odd that everything worked with that exact same config in the previous interface.

    Thank you to everyone for the help! I really appreciate it!



  • @flyscha I think in general, slicers will default to using T0 if no tool is selected when slicing. If they don't put a T(n) command in the gcode file then you'd be fine, but if you used slicer which did put a T(n) command in, then the default would be T0. So defining your single tool as T0 in your config.g is the safer option.



  • @deckingman Ok, great. Thank you for the explanation, that makes complete sense!


Log in to reply