Adding dual z stops



  • This is for the Tronxy X5S dual z screws. I am trying to add dual limit switches for the z both normally closed I added the jumpers back to ZB and connected the second z stepper to E0 I have rewritten my config.g included below does this all seem correct?
    RepRap firmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.03 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2019-06-13b2
    Thank you
    Tom

    Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.0 on Sun Sep 01 2019 15:25:16 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Tronxy X5SA" ; set printer name

    ;M667 S1 ; select CoreXY mode
    M669 K1 ; select CoreXY mode
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss

    ;DUAL Z
    M584 X0 Y1 Z2:3 U3 E4 P3

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards X
    M569 P1 S1 ; physical drive 1 goes forwards Y
    M569 P2 S0 ; physical drive 2 goes backwards z
    M569 P3 S0 ; physical drive 3 goes backwards second z
    M569 P4 S1 ; Drive 4 goes forwards Extruder

    M350 X64 Y64 Z64 U64 E16:16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E439.00 ; set steps per mm
    M566 X600.00 Y600.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z180.00 E1500.00 ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E10000.00 ; set accelerations (mm/s^2)
    M906 X950 Y950 Z950 E950 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X330 Y330 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 U1 S1 ; set active high endstops
    M558 P0 X0 Y0 Z0 H2 F60 T6000 ; Set Z probe type to switch, the axes for which it is used and the dive height + speeds
    G31 P600 X0 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:300 Y15:300 S20 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    ;M307 H1 A748 C185.9 D11.3 V24.1 B0
    M143 H1 S290 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Network
    M552 S1 ; enable network
    M587 00000000000000000000000 ; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Custom settings are not defined

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory



  • @drthomasw3 said in Adding dual z stops:

    0

    one mistake M563 P0 D0 H1 F0 ; define tool 0 should be M563 P0 D1 H1 F0 ; define tool 0

    loaded and tested
    x and y home fine but when homing z, there is no movement and the following pops up !M28 Error: G0/G1: Insufficient axes homed
    the z is away from the limit switches also tried with the z limit switches triggered. how do I clear this? Is it caused by my settings in a config file?
    homez.g
    ; Lift Z relatively to current position
    G91
    G1 Z2 F6000

    ; split Z motor control to Z and U
    ; for it to work we have to show U (param P4) in the UI
    M584 Z2 U3 P4

    ; Move Z and U down until the switches triggers
    G1 S1 Z-205 U-205 F1000
    ; back to combined axes and hidden U
    M584 Z2:3 P3

    ; Back to absolute positioning
    G90

    ; Tell the firmware where we are
    G92 Z0

    ; lift Z after probing, without endstop protection
    G91
    G1 S2 Z10 F1000
    G90



  • Error caused by
    G91
    G1 Z2 F6000
    not sure why
    Z moves fine when Homing x and y



  • Solved
    G1 Z2 F6000 changed to G1 S2 Z2 F6000


Log in to reply