Motor fase error while homing



  • Hello (again :S)
    One more step 1 more question:s
    I am done with the vibration and temp problems but now while homing i get the following warning:
    warning

    Gcode:
    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E100.00 ; set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z180.00 E6000.00 ; set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; set accelerations (mm/s^2)
    M906 X1300 Y1300 Z1300 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-33 Y-10 Z0 S1 ; set axis minima
    M208 X220 Y220 Z240 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; set active low and disabled endstops
    M574 Z1 S2 ; set endstops controlled by probe



  • note:
    Board: Duet WiFi 1.02 or later
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.0 (2020-01-03b3)
    Duet WiFi Server Version: 1.23



  • I just figured out that the homex macro was lifting the Z-axis that was disconnected, i am sorry :S


  • administrators

    @johny, I'm glad you solved it!


Log in to reply