z probe tuning



  • hello
    my printer was originally a maker select v2 Cartesian
    i have a duet 2 wifi v1.04
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.0 (2020-01-03b3)
    Duet WiFi Server Version: 1.23

    i have been trying to get mesh compensation working since i just got me a NPN probe got it hooked up 12v in and connected to z probe in port. once i send g29 for some reason the head moves to x0 y0 making it so my probe is off the build plate attached is my config.g and homez, and home all... managed to get home commands working after a lot of trial and error and research. i have followed the steps on here and still having issues.

    any help or guidance would be greatly appreciated thanks
    homez.g homeall.g config.g


  • Moderator

    Are you sure the Z probe X Y offset and grid is correct?

    G31 P500 X26 Y47 Z2                                ; set Z probe trigger value, offset and trigger height
    M557 X10:190 Y10:190 S20                           ; define mesh grid
    

    Does -X travel to the left, and X+ to the right? -Y to the front, and Y+ to the back?



  • my probe is in front and to the left of the hot end so i have to move y forwards and x to the right to get to 0,0 so am i missing the "-" sign?


  • Moderator

    Yes it sounds like your Y offset should be negative if the 0,0 origin point is at the front left.



  • @Phaedrux thanks bud had to add "-" to both x and y and now its off to the races


  • Moderator

    @bzad said in z probe tuning:

    add "-" to both x and y

    Ah yes, of course. To the left.


Log in to reply