DSF Upgrade Problem



  • When trying to upgrade via SBC I get this:

    pi@Duet3:~ $ sudo apt-get update
    Get:1 https://pkg.duet3d.com unstable InRelease [2,565 B]
    Get:2 https://pkg.duet3d.com stable InRelease [2,563 B]
    Get:3 https://pkg.duet3d.com unstable/armv7 armhf Packages [22.1 kB]
    Get:4 https://pkg.duet3d.com stable/armv7 armhf Packages [9,426 B]
    Get:5 http://archive.raspberrypi.org/debian buster InRelease [25.1 kB]
    Get:6 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
    Get:7 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13.0 MB]
    Get:8 http://archive.raspberrypi.org/debian buster/main armhf Packages [277 kB]
    Fetched 13.4 MB in 47s (286 kB/s)
    Reading package lists... Done
    pi@Duet3:~ $ sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    vlc-bin : Depends: libvlc-bin (= 3.0.8-0+deb10u1+rpt1) but 3.0.8-0+deb10u1+rpt7 is to be installed
    vlc-plugin-skins2 : Depends: vlc-plugin-qt (= 3.0.8-0+deb10u1+rpt7) but 3.0.8-0+deb10u1+rpt1 is to be installed
    E: Broken packages
    pi@Duet3:~ $

    Any Ideas what the problem is. BTW I am using the unstable distro.



  • I am not 100% certain... but were this me, I'd try two things, in order:

    First,

    • sudo apt-get install autoclean

    Then run the regular pair of update/upgrade.

    If that does not work:

    • sudo apt-get install libvlc-bin
    • sudo apt-get install vlc-plugin-qt

    And then go back and run the regular pair of update and install commands. It can't really hurt anything... you can always un-install them.



  • @Danal said in DSF Upgrade Problem:

    sudo apt-get install vlc-plugin-qt

    Thank you. Installing the missing dependencies worked!


Log in to reply