Updated Firmware Can't connect to it now



  • I have duet 2 wifi v2 with panelduo v2

    I updated the firmware to PanelDue-5.0i-7.0i.bin

    Nothing is working properly now.

    To begin with, it says wifi is connected,
    "WiFi module is connected to access point blablablaname, IP address 192.168.1.47.

    But I cannot connect to it from browser at all.


  • Moderator

    Is the blue LED on the module lit?



  • yes it is



  • M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 3.0 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-01-03b3
    ok


  • Moderator

    I think the only thing that changed when you updated the PanelDue is that it now has some popup messages at boot such as you saw about what AP you're connected to.

    With the wifi LED lit up, that would indicate that your config has M552 S1 in there to enable the module, and the connection popup would indicate that it's successfully connected to the AP.

    So what happens in the browser when you go to that 192.168.1.47 IP address?

    Are you able to ping that address from the command line?

    Are you able to check your router config page to see what is connected?



  • @Phaedrux M503
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Feb 09 2019 18:37:46 GMT+0000 (GMT)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"TronXY X5SA" ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable/Disable HTTP S0=disable S1=enable
    M586 P1 S1 ; Enable/Disable FTP
    M586 P2 S1 ; Enable/Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes backwards
    M671 X421:-111.5 Y162:162 S5 ; leadscrews at mid left, and mid right
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z100.00 E800 ;E1025 ; Set steps per mm
    M566 X600.00 Y600.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    ;M203 X9000.00 Y9000.00 Z180.00 E1500.00 ; -origional- Set maximum speeds (mm/min)
    M203 X9000.00 Y9000.00 Z800.00 E700.00 ; Set maximum speeds (mm/min)
    ;M201 X3000.00 Y3000.00 Z250.00 E12000.00 ; Set accelerations (mm/s^2)
    M201 X3000.00 Y3000.00 Z250.00 E700.00
    ;M906 X1250.00 Y1250.00 Z1250.00 E1250.00 I30 ; -origional- Set motor currents (mA) and motor idle factor in per cent
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30

    ; Axis Limits
    M208 X0 Y0 Z-1.0 S1 ; Set axis minima
    M208 X330 Y330 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active high endstops
    M574 Z1 S2 ;Define Z to use Probe. Home to Min.
    ;M591 D0 P2 C3 S1 ; Filament sensor on for E0 extruder, simple NO switch connected to E0

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 ;last set >H20<, Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-20 Y-45 Z1.50; Set Z probe trigger value, offset and trigger height
    M557 X30:315 Y15:315 S130 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 S"Bed Heater" ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.06e-8 R4700 S"Hot End Heater" ; Set thermistor + ADC parameters for heater 1
    ;M305 P1 T100000 B4138 R4700
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ;Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    M501 ; read eeprom parameters
    ok



  • @Phaedrux Pinging 192.168.1.47 with 32 bytes of data:
    Reply from 192.168.1.47: bytes=32 time=4ms TTL=255
    Reply from 192.168.1.47: bytes=32 time=4ms TTL=255
    Reply from 192.168.1.47: bytes=32 time=4ms TTL=255
    Reply from 192.168.1.47: bytes=32 time=23ms TTL=255

    From console.

    But chrome or ie i get "This site can’t be reached192.168.1.47 refused to connect."



  • Its up now.

    Not sure what made the difference.


  • Moderator

    So you've updated to firmware 3.0 as well?

    Your config.g will need some substantial changes to work with RRF3.

    I suggest either reverting to 2.05 (manually putting the firmware file on the SD card and sending the update command via the paneldue console)

    Or if you intend to migrate to RRF3 generate a new config set using the web configurator.



  • @Phaedrux What do you reccomend? Is the 3.0 worth upgrading to?


  • Moderator

    Well it will be the way to go in the near future, but currently if all you want to do is print I would suggest sticking to 2.05.


Log in to reply