Web interface hangs after partial page load



  • I have a SeemeCNC Artemis with Duet that is 18 months old. Firmware info is below. I have been using it with the web interface exclusively.

    Recently, I began having trouble loading the web control page. It usually loads just part of the page and then hangs. If I keep refreshing it 10-20 times, I can sometimes get it to load completely.

    If I keep a local copy of the html page on my PC, and give it the IP address, it will connect and function in controlling the printer.

    But it also frequently hangs on uploading of a gcode file. That requires multiple cancel/retries also.

    These symptoms seemed to point to the microSD card interface, so I replaced the microSD card, but that did not fix the problem.
    Both the original and the new cards are Sandisk 16GB Class 10 cards

    Can anyone advise me on what to check next? I could pull the Duet board out and check it for physical problems.

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 1.21 (2018-03-21)
    WiFi Server Version: 1.21
    Web Interface Version: 1.21
    Web Interface by Christian Hammacher
    Licensed under the terms of the GPL v3



  • Has your wireless network changed in anyway, access point moved, printer moved?
    As another suggestion, maybe upgrade the firmware to a later version such as 2.05?

    HTH
    Paul



  • @PaulHew

    I did get a new router recently, but it is actually somewhat closer to the printer, so I did not think it was a likely suspect.


  • Moderator

    @mechg said in Web interface hangs after partial page load:

    I did get a new router recently

    Perhaps it's on a different channel than before? Or has worse 2.4ghz performance?

    Even though it's closer it may have a dead zone or shadow in the direction of the printer.

    Your firmwares are all rather out of date at this point as well. It may be worth upgrading. There have been improvements to both the wifi server and DWC to help with disconnects in general.

    @mechg said in Web interface hangs after partial page load:

    Sandisk 16GB Class 10 cards

    How were the cards formatted? If in doubt, use the SD Card Formatter from the SD card association.



  • @Phaedrux

    Both cards are fat32. If one was incorrectly formatted, wouldn't it fail completely, rather than working part of the time?


  • Moderator

    @mechg Well if the cluster size was completely wrong it could lead to really bad performance reading and writing to the card.

    The cluster size should be as large as possible. For Fat32 the largest you'll be able to get with the windows formatter tool is 32kb which should be acceptable.



  • @Phaedrux I will try loading the latest firmware this weekend, and if that does not help, then I will reformat the new card and try it. Thanks.



  • So I upgraded to the latest stable firmware release, RR3, and that did not help the unreliable communication.

    I then went back to the latest firmware release officially supported by SeemeCNC, which is 1.21.

    After copying everything on and off the microSD card, I don't see any signs of any performance issues with the card.

    The Duet diagnostics shows RSSI at -66dBm, which the Duet docs say is marginal. My router is set to channel 1 for 2.4gHz.

    I have ordered a wifi extender to put in the room with the printer to see if that helps.


  • Moderator

    @mechg said in Web interface hangs after partial page load:

    WiFi Server Version: 1.21

    It's this part that is the most out of date, and likely to cause problems, possibly with your new router. It's also not ideal to run current firmware on the older WiFi Server versions. If you can bear it, I'd update the WiFi Server version and firmware to the latest non-RepRapFirmware 3 (to avoid having to change a lot in your config.g) which is v1.23 for the WiFi Server, 2.05.1 for the RepRapFirmware, 2.07 for DWC, then test again. All of these are here: https://github.com/dc42/RepRapFirmware/releases/tag/2.05.1

    If you want to revert to RRF 1.21, you'll need to downgrade the Wifi server back to 1.21, I think.

    I would use the 'official' SD card formatting software https://www.sdcard.org/downloads/formatter/index.html to make sure the SD card is formatted at it's best; 'Quick format' on Windows is pretty much the worst option for formatting them. You wouldn't see an issue copying things on and off the card if it's inserted in your PC, but it can support far more formatting schemas than the Duet can.

    Ian



  • Thanks, but I feel motivated to stick with the versions that SeeMeCNC recommends for the hardware that I have, if possible. They supply an install package with the following:

    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.22
    Web Interface Version: 1.22.6

    I just switched my router from automatic, where it was selecting channel 1, to fixed channel 6 and it is behaving much better.

    On channel 1, the Duet was reporting -66dBm signal, but on channel 6 it reports -50dBm. That's a big improvement.

    If it continues to behave for a day or two, I will mark this as solved.



  • In spite of having better signal strength it was still unreliable when loading the Web Control page. So I added a secondary 2.4gHz access point Using a Netgear extender connected to my gateway/router over ethernet. The Duet seems to be loading the page more reliably now, but I won't consider it solved until it works fine for a couple of weeks.

    I don't know why the gateway (ATT provided BGW210) would have trouble talking directly to the Duet, but maybe it does.


  • administrators

    Is the 2.4GHz WiFi spectrum crowded where you live? I know from personal experience (at an exhibition) then when the spectrum is crowded, changing the WiFi channel can make a lot of difference to a Duet WiFi with internal antenna, even if the signal strength is good. In that instance I used a smartphone app to display all the existing APs in the area and choose a quiet channel.


Log in to reply