Problems with XY Homing



  • Good Morning,i have Problems to home my X and Y axis. The LED on the board is not on, but the board thinks the endstop is triggered.

    So if i want to home e.g X the carriage will move some mm to one side and than says that it is homed. But when i close the endstop and home X, the printer wants to home untill i release the endstop.

    I tried all Possible configuration and i dont now what im doing wrong.

    I have 2 phases Endstops, i dont now if they are NO ore NC. I trief both configuration but nothing worked.

    H had the same problem with the Z axis until i added I1 in config.g for Z Probe, but that didnt worked for the other axis.

    Config.g:

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Feb 11 2020 10:36:53 GMT+0100 (Mitteleuropäische Normalzeit)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Anet E12" ; set printer name

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X950 Y950 Z950 E950 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X310 Y310 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-low endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-low endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M558 P5 C"zprobe.in+zprobe.mod" H5 F120 T6000 I1 ; set Z probe type to switch and the dive height + speeds
    G31 P500 X25 Y25 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:290 Y15:290 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S100 ; set temperature limit for heater 0 to 100C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • @MauriceM I sounds like you need to invert the input. It also looks like you using RRF3 so the "I" parameter won't work. Instead you need to put "!" before the pin name. So M574 X1 S1 P"!xstop" instead of M574 X1 S1 P"xstop"



  • @MauriceM said in Problems with XY Homing:

    M574 X1 S1 P"xstop" ; configure active-low endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-low endstop for low end on Y via pin ystop

    try to invert your endstops with:

    M574 X1 S1 P"!xstop" ; configure active-low endstop for low end on X via pin xstop
    M574 Y1 S1 P"!ystop" ; configure active-low endstop for low end on Y via pin ystop
    


  • Thanks, it workes flawless. now i have to change the motor to the right direction and it will work.

    But why did the I1 on the Z Probe worked? bevor that change the z probe was also triggered the whole time.


  • administrators

    @MauriceM said in Problems with XY Homing:

    Thanks, it workes flawless. now i have to change the motor to the right direction and it will work.

    But why did the I1 on the Z Probe worked? bevor that change the z probe was also triggered the whole time.

    Currently, the I parameter on the M558 command is still supported, but it will probably be removed in a future firmware version.



  • @MauriceM said in Problems with XY Homing:

    But why did the I1 on the Z Probe worked?

    it seems that this is not removed in rrf3 if you want to make it right then add ! and remove I1 to this line

    M558 P5 C"!zprobe.in+zprobe.mod" H5 F120 T6000  ; set Z probe type to switch and the dive height + speeds
    


  • Ah ok, i will change it. Thanks


  • Moderator

    @MauriceM said in Problems with XY Homing:

    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    If you're using the Z probe for homing Z, and have no endstop, this should be M574 Z0.

    Ian



  • but its working so i dont have to change it or will it cause problems?


  • Moderator

    @MauriceM It's fine to leave it if you home Z using G30. But if, by mistake, you try using (or your homing.g files contain) a G1 H1 (ie a homing move) on Z, it will try to use the non-existant endstop, rather than the probe, to home Z, resulting in a crash. Better to remove the chance!

    Ian


Log in to reply