Can't get stealthChop2 to work on Duet 3



  • I just finished installing Duet 3 as a replacement for my Duet 2 Wifi.

    I bought it in hopes I could run 2 extruders, 2 Z motors on my HEVO and achieve the noise level of a Duet Maestro (seeing as both support stealthchop) that I have installed on my second printer.

    It was a pretty sweet transition - just redo motor cables for bigger AWG, change pinout on the rest - plug in and enjoy... until I started moving it 😉

    While working at very low speeds (sub 5mm/s) - the printer is dead quiet. Amazing!

    But anything above that sounds exactly like the old Duet 2 Wifi.

    I played around with the V parameter going anywhere from 2000 to 100. This did not have any effect on the noise level. Anything above 5mm/s made a lot of noise.

    Setup command is:

    M569 P0.0 S0 D3 V####
    

    Here are the results of M569 P0:

    Maestro:

    Drive 0 runs in reverse, active low enable, step timing fast, mode stealthChop, ccr 0x00053, toff 3, tblank 0, hstart/hend/hdec 5/0/0, tpwmthrs 2000 (4.7 mm/sec)
    

    Duet3:

    Drive 0 runs in reverse, active low enable, step timing fast, mode stealthChop, ccr 0x08053, toff 3, tblank 1, hstart/hend/hdec 5/0/0, pos 376, tpwmthrs 2000 (4.7 mm/sec), thigh 200 (46.9 mm/sec)
    

    Has anyone else figured this out? I'd expect Duet 3 to be even quieter than Maestro ;/

    Details on setup:
    Hypercube Evolution
    Duet 3 MB 6HC 1.0
    FIRMWARE_NAME: RepRapFirmware for Duet 3 MB6HC v0.6 or 1.0 FIRMWARE_VERSION: 3.01-RC1 ELECTRONICS: Duet 3 MB6HC FIRMWARE_DATE: 2020-02-08b3



  • @pkos said in Can't get stealthChop2 to work on Duet 3:

    tpwmthrs 2000 (4.7 mm/sec)

    if you set it to this then it switches to spreadcycle after 4.7mm/sec

    @pkos said in Can't get stealthChop2 to work on Duet 3:

    I played around with the V parameter going anywhere from 2000 to 100

    i currently use a value of 30 on my maestro.

    @pkos said in Can't get stealthChop2 to work on Duet 3:

    M569 P0.0 S0 D3 V####

    have you done this for all drivers?



  • The answers to the above are:

    1. Yes, I get that, but as I said - I tried a lot of values - from 2000 to 100. It was always the same noise above 5 mm/s.
    2. OK. I will try that, although I didn't have to change anything on the Maestro. It's just nearly dead silent.
    3. Yes, of course 🙂 And during testing, I was only testing one motor - not both at the same time.


  • @pkos said in Can't get stealthChop2 to work on Duet 3:

    I'd expect Duet 3 to be even quieter than Maestro

    although I didn't have to change anything on the Maestro

    Meastro made for small machines and has stealthchop enabled by default. duet2wifi and duet3 are made for larger machines and have spreadcycle enabled by default. you could try tuning the various chopper control register parameters.



  • @bearer said in Can't get stealthChop2 to work on Duet 3:

    @pkos said in Can't get stealthChop2 to work on Duet 3:

    I'd expect Duet 3 to be even quieter than Maestro

    although I didn't have to change anything on the Maestro

    Meastro made for small machines and has stealthchop enabled by default. duet2wifi and duet3 are made for larger machines and have spreadcycle enabled by default. you could try tuning the various chopper control register parameters.

    And here you are touching exactly on my problem. Before I start doing that, I was hoping someone else has done this and could save me some time.

    I am aware that Maestro has stealthChop on by default. That's why I enabled it manually on the HEVO with M569 and D3 in there.

    The thing that bugs me the most is that no matter what speed I set using the V parameter - anytime I go over 5mm/s - it seems like stealthChop gets disabled.

    In the example above you see tpwmthrs set to 2000. But it's the same even with 100...



  • @pkos said in Can't get stealthChop2 to work on Duet 3:

    I was hoping someone else has done this

    it'd be specific to your setup in any case (motor spec, supply voltage, mechanical loads etc)



  • In a way I would agree, but this is not the core of the problem.
    Let me reiterate my issue.

    1. I have a duet3 6 hc connected in a HEVO build.
    2. I configure the motors via M569 in two configurations.
      a) Stealthchop (via D3)
      b) Spreadcycle (no extra settings - raw config as it comes out of RepRap Configurator)
    3. I have adjusted the V parameter a lot going anywhere from 30 all the way to 2000.

    There is NO difference in sound regardless of which config I use if the speed is above 5 mm/s.

    I can set V to go all the way to 100 mm/s - still - the noise generated by the motors will be the same for either configuration setup. This is not what I am expecting.

    With stealthchop turned on - if it works - I should be able to hear the difference regardless of what motors/wires/belts I have. But here I do not and the noise is as if Spreadcycle was always on (above 5 mm/s - below that I do hear a difference).


  • Moderator


  • administrators

    I think you may find that stealthChop works without using that workaround in RRF 3.01-RC2.


  • Moderator



  • Thank you both for the suggestions.

    @Phaedrux - thanks for the hint. I know that thread. I think you'll find I already commented there 🙂

    I'll test RC2 again and in the meantime wait for RC3 and the change to lwip.


Log in to reply