Bed mesh generation



  • HI,

    After following the guide and setting my offsets, when running G29 the probing starts at X5 and Y3. In config.g i have defined M557 X50:300 and Y15:285. My Probe is on the left of the nozzle so when the mesh starts at X5 and Y3 the probe is outside the bed area. Im using an NPN cap sensor btw.

    Here is my config.g

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.4 on Fri Dec 27 2019 23:39:02 GMT+0100 (sentraleuropeisk normaltid)
    
    ; General preferences
    G90                                      ; send absolute coordinates...
    M83                                      ; ...but relative extruder moves
    M550 P"CR-10"                            ; set printer name
    
    ; Network
    M551 P"********"                         ; set password
    M552 S1                                  ; enable network
    M586 P0 S1                               ; enable HTTP
    M586 P1 S0                               ; disable FTP
    M586 P2 S0                               ; disable Telnet
    
    ; Drives
    M569 P0 S1                               ; physical drive 0 goes forwards
    M569 P1 S1                               ; physical drive 1 goes forwards
    M569 P2 S0                               ; physical drive 2 goes forwards
    M569 P3 S1                               ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                         ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                  ; configure microstepping with interpolation
    M92 X80 Y80 Z400.00 E101.00         	 ; set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00      ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00  ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E10000.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30             ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                  ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                         ; set axis minima
    M208 X300 Y300 Z400 S0                   ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 S0                            ; set active low and disabled endstops
    M574 Z1 S1                               ; set active high endstops
    
    ; Z-Probe
    M558 P5 H5 F120 T6000                    ; set Z probe type to modulated and the dive height + speeds
    G31 P500 X45 Y12 Z1.57                    ; set Z probe trigger value, offset and trigger height
    M557 X50:300 Y15:285 S20                  ; define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                         ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700              ; set thermistor + ADC parameters for heater 0
    M143 H0 S120                             ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700              ; set thermistor + ADC parameters for heater 1
    M143 H1 S300                             ; set temperature limit for heater 1 to 300C
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                   ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1 F0                         ; define tool 0
    G10 P0 X0 Y0 Z0                          ; set tool 0 axis offsets
    G10 P0 R0 S0                             ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    


  • Is your probe to the left or right of your nozzle?
    Assuming its on the left and to the right is +x you need to change your nozzle offset from +45 to -45.
    Same goes for the Y offset of your probe too



  • if your probe is on the left, shouldn't the X-offset be negative?



  • You are absolutely right! Thank you! Don't know how i missed that...


Log in to reply