2000 degrees after restoring config



  • Hello,

    I had my printer working but then randomly I couldn't get it to connect to the web page but would connect to wifi. I started completely fresh and redid everything. I have everything working except the Z axis keeps homing in the wrong direction (ender 5) and now the bed and hotend both show 2000 degrees. Both ohm out as they should, bed ohms at 100k (ac heater and mosquito with high temp thermistor). I am not sure what to try, everything is connected the same way as it was when the printer was previously working.

    Here is what my config file looks like:

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes forwards
    M569 P1 S0 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E830.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X230 Y230 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z2 S1 P"!zstop" ; configure active-high endstop for high end on Z via pin !zstop

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:215 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S175 ; set temperature limit for heater 0 to 175C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T500000 B4723 C1.19622e-7 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S450 ; set temperature limit for heater 1 to 450C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    Thank you in advance,
    Craig



  • @craigrezac7 said in 2000 degrees after restoring config:

    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M308 S1 P"e0temp" Y"thermistor" T500000 B4723 C1.19622e-7 ; configure sensor 1 as thermistor on pin e0temp

    I don't know that your T and B and C are or aren't correct... I can say that I have E3D hot ends, and have an identical thermistor on the bed, and this works for me:

    ; Temperature sensors
    M308 S0 P"0.temp0" Y"thermistor" T100000 B3950 A"Bed" 
    M308 S1 P"1.temp0" Y"thermistor" T100000 B3950 A"HE1"
    M308 S2 P"1.temp1" Y"thermistor" T100000 B3950 A"HE2"
    M308 S3 P"2.temp0" Y"thermistor" T100000 B3950 A"HE3"
    M308 S4 P"2.temp1" Y"thermistor" T100000 B3950 A"HE4"
    

    Also, iIf you unplug a sensor (thermistor) what does it show? If I recall, 2000 is the "magic number" that indicates a short, so what does that input read with nothing plugged in? If it switches to -273.x, that may indicate a wiring problem.


  • administrators

    What version of RepRapFirmware is your board running? Send M115 to find out.



  • @dc42 Duet 2 Firmware version 2.04, Wifi 1.02 it says.



  • @Danal It reads 2000 no matter what I do. I can plug in a different thermistor all together and still get a short.



  • Try an M308 for your hot end, try one with your pin definition (C) and my thermistor constants.



  • @Danal I looked at the example M308 but I guess I don't understand how I would type it out correctly.



  • I just updated to 3.0 and now it is all working.. strange.. Thank you for all the ideas though.



  • New issue.. It says my bed is heating much slower than expected. 1.6c/sec. It seems to me like its heating fast, how does that get adjusted?


  • Moderator

    @craigrezac7 said in 2000 degrees after restoring config:

    New issue.. It says my bed is heating much slower than expected. 1.6c/sec. It seems to me like its heating fast, how does that get adjusted?

    Perform a PID tuning on your bed heater.



  • @craigrezac7 said in 2000 degrees after restoring config:

    M308 S1 P"e0temp" Y"thermistor" T500000 B4723 C1.19622e-7 ; configure sensor 1 as thermistor on pin e0temp

    @Danal said in 2000 degrees after restoring config:

    M308 S1 P"1.temp0" Y"thermistor" T100000 B3950 A"HE1"
    Suggested thing to try:

    M308 S1 P"e0temp" Y"thermistor" T100000 B3950



  • Just because it doesn't error... doesn't mean it is reading correctly...

    Does your hotend read in the low 20s C when at room temperature?



  • @Danal Yes, they are both where they should be now. Like I said, they used to work then all of a sudden decided not to. I did do PID tunes a bit ago. I will try heating again in a bit. I have 7 other FDM printers but all Marlin so this is new to me even though I've had it a few months. Thank you for the help thus far. I just have to figure out what to change to get the bed to home in the correct direction now.


  • administrators

    @craigrezac7 said in 2000 degrees after restoring config:

    I just have to figure out what to change to get the bed to home in the correct direction now.

    This may help https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_files.


  • Moderator

    @craigrezac7 I think the problem has been caused by having RRF 2.04 on the Duet, but creating a config.g for RRF 3 (there are a lot of differences!). Now you have updated the board to RRF 3, it's working. As you started with a blank SD card, you've lost any settings that you had before, unless you kept a copy. So you're effectively setting up this printer as a new machine. Follow the commissioning guide: https://duet3d.dozuki.com/Wiki/Step_by_step_guide#Section_Commissioning_tests

    For the Z endstop, you have configured:

     M574 Z2 S1 P"!zstop" ; configure active-high endstop for high end on Z via pin !zstop
    

    You've inverted the Z endstop with the "!" character, so it may be reporting that the Z endstop is triggered when it is not. This means when you send a homing move, it's seeing the endstop as triggered, and is trying to move away from it. Send M119 to see the endstop status, and press the endstop. It's also set to be at the top, ie with nozzle furthest from the bed.

    Ian



  • @droftarts Endstops - X: at min stop, Y: at min stop, Z: not stopped, Z probe: at min stop - Thats what I get with M119. When I go to home Z, it just keeps lowering the bed until I hit stop.


  • Moderator

    Post your homez/homeall



  • @Phaedrux ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Feb 18 2020 11:10:45 GMT-0500 (Eastern Standard Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-235 Y-235 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-235 Y-235 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G1 H1 Z305 F360 ; move Z up stopping at the endstop
    G90 ; absolute positioning
    G92 Z300 ; set Z position to axis maximum (you may want to adjust this)

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Feb 18 2020 11:10:45 GMT-0500 (Eastern Standard Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 Z305 F1800 ; move Z up until the endstop is triggered
    G92 Z300 ; set Z position to axis maximum (you may want to adjust this)


  • Moderator

    Is your z endstop at the high end of travel? IE farthest away from the nozzle?

    When you jog the Z axis does + take it away from the nozzle and - towards the nozzle?



  • @Phaedrux It is on an Ender 5, + and - do work correctly, it just tries to find the limit switch going the wrong way, the bed lowering till I make it stop by pressing the limit switch or hitting stop, instead of raising the bed up and hitting the limit switch.


  • Moderator

    @craigrezac7 said in 2000 degrees after restoring config:

    ; homeall.g
    G1 H1 Z305 F360 ; move Z up stopping at the endstop

    ; homez.g
    G1 H1 Z305 F1800 ; move Z up until the endstop is triggered

    It's these two lines, which are moving the bed to maximum Z, which is down. The 'up' comment is confusing, because the config tool is assuming the X axis moves up, not the bed moving down. What it does is increase the distance between nozzle and bed, which is a positive Z movement. What you want is a negative Z movement, to bring the bed and nozzle closer together. Change both to G1 H1 Z-305 F360. The feed rate 'F' doesn't matter too much, as your Z axis is probably limited to 3mm/s, or 180mm/min, which is F180.

    Also, I think you need to change the Z endstop definition again. You did have:

    M574 Z2 S1 P"!zstop" ; configure active-high endstop for high end on Z via pin !zstop

    The 'Z2' is for a 'max' endstop, ie bed furthest from nozzle, so bed moves down. Again the 'high end' comment is somewhat confusing, assuming it's the X axis that is moving up, not the bed moving down, so this should be Z1. I mentioned that you inverted the endstop with '!' earlier, which changes the behaviour of the endstop to report 'not stopped' when pressed, and 'at min stop' when not pressed. Did you change this? Change this to M574 Z1 S1 P"zstop".

    Before homing, test your endstop by sending M119. With the Z axis not activating the endstop, it should say 'Z: not stopped'. Then press and hold the Z endstop, and send M119. Should then say 'Z: at min stop'.

    Ian



  • @droftarts I did switch that ! after you mentioned it last time. I am horrible with coding. That did fix the issue though, the -305. Thank you very much. That makes perfect sense now that you say it.



  • Hey,

    I have the same issue with my board.
    Installed 3.0 and changed 308/950 comands as per example.
    Both sensors shows 2000C

    Am I missing something?


  • Moderator

    @Alishkus said in 2000 degrees after restoring config:

    Hey,

    I have the same issue with my board.
    Installed 3.0 and changed 308/950 comands as per example.
    Both sensors shows 2000C

    Am I missing something?

    Best to start a new thread with some more details about your setup. Include your config, and how you have everything wired.



  • This post is deleted!

Log in to reply