Setting Z probe and mesh compensation in config g



  • Good afternoon
    Please help with the Сonfig file for Duet Wi Fi version 2.03. generated by RepRapFirmware Con.Tool v2.1.6
    I assembled a Cartesian printer where XY moves in the same plane with ball screws and 3 step motors
    the Z table is lowered with balls crews and 2 step motors. I connect inductive sensor NPN normally open. The problem is that I can’t level table with Z ptobe and I can’t get a mesh bed compensation.
    Please help me what am I doing wrong
    kind regards
    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.6 on Tue Jan 14 2020 10:57:13 GMT+0300 (Москва, стандартное время)
    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Gnutik" ; set printer name
    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet
    ;***************************************
    ; M564 S0 H0
    ;***************************************
    ; Drives
    M569 P3 S1 ; physical drive 3 goes forwards Extruder
    M569 P0 S0 ; physical drive 0 goes forwards drive Y
    M569 P1 S0 ; physical drive 1 goes forwards drive Y
    M569 P2 S0 ; physical drive 2 goes forwards drive X
    M569 P5 S0 ; physical drive 5 goes forwards drive Z
    M569 P6 S0 ; physical drive 6 goes forwards drive Z
    M584 X2 Y0:1 Z5:6 E3
    ;***********************
    M671 X-27:980 Y21:21
    ;***********************
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X400.00 Y400.00 Z1280.00 E418.50 ; set steps per mm
    M566 X400.00 Y400.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z600.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X400.00 Y400.00 Z10.00 E250.00 ; set accelerations (mm/s^2)
    M906 X1800 Y1800 Z1800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    ; Axis Limits
    M208 X300 Y200 Z0 S1 ; set axis minima
    M208 X750 Y450 Z500 S0 ; set axis maxima
    ; Endstops
    M574 X0 S0 "X-stop"
    M574 Y0 S0 "Y-stop"
    M574 Z0 S0 "Z-stop"
    ; Z-Probe
    M558 P5 I1 H5 F120 T6000
    G31 X0 Y0 Z0,1
    M557 X30:740 Y0:450 S20 ; define mesh grid
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    ; Custom settings are not defined
    M501



  • @Vladimir said in Setting Z probe and mesh compensation in config g:

    M574 Z0 S0 "Z-stop

    You need to remove the above setting and just leave the M558 command, my RRF2 setting were :

    ; Endstops - these are for standard standard switched X low, Y high, active low

    M574 X1 Y2 S0 ; Set active low endstops

    M558 P8 I1 R0.5 H5 T24000 F250 A0 S0.04 ; Set Peizo - P probe type, I Invert, R recovery time, H dive hight, T inter-probe-point speeds, F Probing Speed, 3 Dives , S calculated difference


  • Moderator

    @Vladimir Please send M115 to your Duet and post the reply. Your config.g is for RepRapFirmware 3, not 2.03.

    Assuming you are using RRF 3, your endstop configuration is wrong. Your have:

    ; Endstops
    M574 X0 S0 "X-stop"
    M574 Y0 S0 "Y-stop"
    M574 Z0 S0 "Z-stop"
    

    See https://duet3d.dozuki.com/Wiki/Gcode#Section_M574_Set_endstop_configuration
    'X0' 'Y0 and 'Z0' disables the endstop, so you have no endstops enabled.
    'S0' sets the endstop type to active low endstop input. If you are using microswitches as endstops, using active high (NC/Normally Closed) is recommended; see https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches#Section_Microswitch.
    The input pin needs the parameter 'P', eg P"X-stop".

    Change to this and test:

    ; Endstops
    M574 X1 S1 P"xstop"                            ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop"                            ; configure active-high endstop for low end on Y via pin ystop
    

    For the probe, as @Dr_Ju_Ju said above, change the Z probe configuration. Also, you will need to check your homing gcode files, particularly for Z. They may be using G1 H1 Z moves, it should use G30.

    Ian



  • you are right I send M115 - the reply: RRF for Duet Wi Fi/ Ethernet Firmvare_version:3.0 Electronics: Duet WiFi 1.02 or later + duex5 firmware_date:2020-01-03b3
    20200226_111457[1].jpg



  • So far,the movements of top portal and z limited by mm and only one end stop
    But adjustment of sensor and compensator I do not understand yet.



  • This post is deleted!


  • Maybe I 'm in the wrong thread having a discussion and it needs to be moved to "Firmware Installation" if yes moderator tell how to do it thank you

    0



  • M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.0 running on Duet WiFi 1.02 or later + DueX5
    Board ID: 08DGM-9T6BU-FG3S4-6J9F0-3S86Q-1ARVF
    Used output buffers: 3 of 24 (13 max)
    === RTOS ===
    Static ram: 30516
    Dynamic ram: 92312 of which 32 recycled
    Exception stack ram used: 504
    Never used ram: 7708
    Tasks: NETWORK(ready,640) HEAT(blocked,1240) DUEX(suspended,160) MAIN(running,3668) IDLE(ready,156)
    Owned mutexes:
    === Platform ===
    Last reset 01:56:42 ago, cause: software
    Last software reset at 2020-02-26 10:46, reason: User, spinning module GCodes, available RAM 7740 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 38.5, current 39.8, max 40.3
    Supply voltage: min 24.0, current 24.3, max 24.7, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max 118/451
    Driver 1: standstill, SG min/max 122/436
    Driver 2: standstill, SG min/max 107/415
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Driver 5: standstill, SG min/max 217/528
    Driver 6: standstill, SG min/max 237/478
    Driver 7: standstill, SG min/max not available
    Driver 8: standstill, SG min/max not available
    Driver 9: standstill, SG min/max not available
    Date/time: 2020-02-26 12:43:31
    Cache data hit count 4294967295
    Slowest loop: 3.20ms; fastest: 0.09ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Move ===
    Hiccups: 0(0), FreeDm: 169, MinFreeDm: 167, MaxWait: 4975468ms
    Bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 14, completed moves: 14, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 15.57ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running


  • absolutely I am in a stupor
    Gives error during diagnostics M122
    G29 no valid grid defined for probe

    config - fragment
    ; Axis Limits
    M208 X300 Y200 Z0 S1 ; set axis minima
    M208 X750 Y450 Z500 S0 ; set axis maxima

    ; Endstops
    M574 X0 S0 "X-stop"
    M574 Y0 S0 "Y-stop"
    ; M574 Z0 S0 "Z-stop"

    ; Z-Probe

    M574 X1 Y2 S0
    ; M558 P5 I1 H5 F120 T6000
    M558 P8 I1 R0.5 H5 T240 F250 A0 S0.04
    G31 X0 Y0 Z0,1
    M557 X30:740 Y0:450 S20 ; define mesh grid


  • Moderator

    @Vladimir M122 is just reporting that no compensation is in use:

    === Move ===
    Hiccups: 0(0), FreeDm: 169, MinFreeDm: 167, MaxWait: 4975468ms
    Bed compensation in use: none, comp offset 0.000

    I see you have M557 in your config.g. Send M557 at the console, what is the response?

    Ian


  • Moderator

    @Vladimir Another option; send M98 P"config.g". This will run your config.g and show any errors.

    Your endstop configuration is still wrong, particularly as you are missing 'P' in "xstop". Comment out all endstop definitions with ';' if you don't have them fitted.

    Ian


Log in to reply