Attempting to extrude with no tool selected



  • I have checked other similar posts but no luck. I cannot get the extruder to respond. It tried it from the web interface and the PaneDue yet the same error keeps popping up when I try an extrude or retract command. This is my code:

    ; Tools
    M563 P0 S"MYTHprint" D0 H1 F0 ; define tool 0
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    Can someone point me in the right direction?



  • did you have this in the near of the end in your config.g ?

    T0                                                  ; select first tool
    


  • @SIam This is at the end, the last entry.


  • administrators

    From the console, send T with no parameters to see whether it reports that tool 0 is selected. Alternatively, check whether Duet Web Control shows Tool 0 as active.



  • @dc42 Sending T on the console returned an error that no tool is selected. On the Duet Web Control I clicked on "Tool 0" and made it active. Now it works on both the PanelDue and the Web Control. Interesting Thanks for the assist.


Log in to reply