RRF 3.0 upgrade leads to 2000c



  • Good day, I just moved to RRF 3.0 from 2.07 and use the config tool to set everything up. But now my hotend and bed are reading at 2000C. no hardware was changed between 2.07 and 3.0. It was printing up until I pushed the new file. hotend is a E3D and bed is a makerbot heated bed from a 2X.

    Config start:

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sat Feb 29 2020 22:08:20 GMT-0700 (Mountain Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X88.00 Y88.00 Z400.00 E2700.00 ; set steps per mm
    M566 X3000.00 Y3000.00 Z12.00 E900.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1800.00 ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z120.00 E250.00 ; set accelerations (mm/s^2)
    M906 X850 Y800 Z400 E550 I10 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-70 Y-127 Z0 S1 ; set axis minima
    M208 X70 Y127 Z155 S0 ; set axis maxima

    ; Endstops
    M574 X1 S0 P"xstop" ; configure active-low endstop for low end on X via pin xstop
    M574 Y2 S0 P"ystop" ; configure active-low endstop for high end on Y via pin ystop
    M574 Z1 S0 P"zstop" ; configure active-low endstop for low end on Z via pin zstop

    ; Z-Probe
    M950 S0 C"exp.heater7" ; create servo pin 0 for BLTouch
    M558 P9 C"zprobe.in+zprobe.mod" H3 F240 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y-19 Z3.5 ; set Z probe trigger value, offset and trigger height
    M557 X-55:55 Y-112:112 S50 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4092 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on !bedheat and map it to sensor 0
    M143 H0 S100 ; set temperature limit for heater 0 to 100C
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on !e0heat and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 C"Part fan" S0 H-1 ; set fan 0 name and value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 C"Hotend fan" S1 H1 T45 ; set fan 1 name and value. Thermostatic control is turned on
    M950 F2 C"fan2" Q500 ; create fan 2 on pin fan2 and set its frequency
    M106 P2 C"Leds" S0 H-1 ; set fan 2 name and value. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss


  • Moderator

    Please send M115 and check your installed firmware version.


  • administrators

    Your BLTouch won't work with your current M559 command. Change the C parameter to C"^zprobe.in".



  • @Phaedrux

    M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.03 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2019-06-13b2

    @dc42
    What M559 are you referring to. I don't see it listed. Are you referring to the M558? and if so do i want to change it to M559?


  • Moderator

    @Hitbox said in RRF 3.0 upgrade leads to 2000c:

    M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.03 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2019-06-13b2

    You've not actually updated the firmware to version 3.



  • Ok which firmware version should be listed? as there seem to be three different Duet3firmware listed in the 3.01 RC3 release?


  • Moderator

    Try 3.0 to start with. You'll need that release first before you can upgrade to the other later versions.



  • Ah there we go. Thank you the temps now are reading nominal. though the push to RC3 seems to be stuck? but i think i found some forum post to get that to work.


Log in to reply