Z moving too much each layer Duet Maestro/CR-10s



  • Hi,

    I hope someone can help- I recently installed a Duet Maestro on my CR-10s and got it working. I'm not good with this type of thing but from the directions and posts here and on Reddit I made it happen.

    My prints always start too high even after doing the paper under the nozzle thing. While I was trying to figure that out, I accidentally entered "g90 z0" instead of using g92 to rest Z position. I'm not sure that's what did it, but since then, or perhaps all along, I've had a weird problem:

    20200304_150026 (1).jpg

    The BLTouch bracket on the right, in blue, was printed with this printer, after installing the BondTech extruder on the CR-10s, but I think it was before Duet Maestro was installed. The left one is the same file.

    In any case, I installed the board, and set it up. When I try to print the same bracket, I get the result you see on the left. I thought it might be because I accidentally set the printer to relative movements as described above, but I've tried sending g90 and I tried adding g90 to the starting script, and I've checked that g90 is in the start of my config file.

    The only change that I have (knowingly) made is to add the command to enable the LCD and that seems to work fine.

    Asking around, It's been suggested to me that if it isn't g90, then maybe my z e-steps are wrong.

    The print starts ok (except I have to baby-step z down some to get it close to the bed despite leveling it) then the second layer will adhere, but by the third layer, the outlines don't stick, and each layer the z gets higher and higher above. I've done several other tests and they all exhibit this behavior.

    I'm using Simplify 3d to slice, which has worked for me before on other printers.

    Any ideas? I'm really stumped. . .

    EDIT: I moved the z axis up "50mm" with the jog controls, and it moved right at 250mm, so it appears to be off by a fcator of 5. If it was a factor of 2 or 4 that would make more sense. . . Anyway I believe that I'm getting 1.25mm of z raise for every ".25mm" the slicer is telling it.

    Hopefully this is a simple noob mistake and someone can set me straight. . .



  • @bluecrayfish In your config.g, you should have a line to define steps/mm, M92 with parameters for X, Y, Z and E. The value for Z should be 400 for CR10. However, it might depend on the position of M350 (microstepping) and the values you enter there. Here is a snippet from my config.g that works:

    M92 X80 Y80 Z400		; Set steps per mm
    M350 X16 Y16 Z16 I1		; X/Y/Z: configure microstepping with interpolation
    

    In M92, I’ve left-out the E parameter because I use a geared extruder instead of the CR10’s original one.


Log in to reply