more Duet3/RRF3 learning pains - dual Z bed leveling?



  • ok so my new Duet3 w/RRF3 is not bed leveling with dual z's as previous with Duet2....here is my code.....what am i doing wrong?

    BED.CFG
    M561 ; clear any bed transform
    G29 H1 ; Clear bed height map
    G30 P0 X30 Y180 H0 Z-9999 ; Center Left
    G30 P1 X275 Y180 H0 Z-9999 S2 ; Center Right
    G29

    CONFIG.G (relevant part only)
    M584 X0.0 Y0.1 Z0.2:0.4 E0.3 ; set drive mapping
    M671 X-50:315 Y0:0 S5 ; Lead screw offsets from home
    M557 X25:295 Y45:295 S110 ; define mesh grid



  • forgot to post i get this message sometimes, not every time i do a G32....but there is nothing wrong with Z offset, it set perfect nearly 0 (0.02)

    G32
    Warning: the height map has a substantial Z offset. Suggest use Z-probe to establish Z=0 datum, then re-probe the mesh.
    9 points probed, min error -0.220, max error -0.056, mean -0.148, deviation 0.056



  • That all looks correct.

    There is a known bug that the results of a level are NOT reported to the console in some releases of RRF3. Are you sure it is or isn't leveling?



  • Not sure this is causing the problem but the y location for the lead screws doesn’t appear to be correct. In M671, both lead screws are at 0:0 for y. Then in your G30 you’re probing at 180 for y. Seems like in M671 y should be 180:180.

    Did you run a G28 before G32?

    Recommend disabling G29 in beg.g until you you get bed leveling working.



  • following



  • its been fine, solved....one of the zmotors was coming loose from the rail....smh



  • @mwolter but the Y axis doesnt matter, as the dual motors can only align the bed across the x -axis, so as long as both Y are the same, it doesnt matter if its 0 or 180....at least how i understood it, and its working ok now.....



  • @imrj said in more Duet3/RRF3 learning pains - dual Z bed leveling?:

    its been fine, solved....one of the zmotors was coming loose from the rail....smh

    It happens... 🙂

    Glad you found it.


Log in to reply