Error: G0/G1:



  • I can't seem to get Kisslicer g codes to work with Duet 2.05.2. Whatever I slice gets this error code: Error: G0/G1: target position not reachable from current position.
    S3d works. I've adjusted start scripts in Kiss to reflect home delta g and home all in Duet settings. Any help would be appreciated!
    Previous versions of Duet worked fine with this board (Duet v 1.02) - Do I need to go back perhaps?


  • Moderator

    Can you provide an example of working S3D gcode and not working kisslicer gcode? Your config files might also be helpful.



  • @Phaedrux ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Fri Mar 06 2020 13:14:57 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"BI 3" ; set printer name
    M665 R273 L425.4 B310 H371.95 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes forwards
    M569 P1 S0 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80 Y80 Z80.00 E2650.00 ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1800.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X1000.00 Y1000.00 Z1000.00 E1200.00 ; set accelerations (mm/s^2)
    M906 X750 Y750 Z750 E400 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; set max Z

    ; Endstops
    M574 X2 Y2 Z2 S0 ; set active low and disabled endstops

    ; Z-Probe
    ;M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    ;M557 R85 S20 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; set temperature limit for heater 0 to 110C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    And:



  • That's config. I'll be back with others. Wait. Not sure how to do those...





  • That was a working S3d file.
    Here is the same File in Kiss:
    1583699703271-kiss-motor-damper.gcode.txt



  • @Phaedrux Files posted, I think - what else can I do to help?


  • Moderator

    In kisslicer it looks like youhave this

    G1 H1 X705 Y705 Z705 F5000 ; move all towers to the high end stopping at the endstops
    G1 H2 X-5 Y-5 Z-5 F3600 ; go down a few mm
    

    Maybe try replacing that with G28


  • administrators

    From your file:

    G91 ; relative positioning

    G1 H1 X705 Y705 Z705 F5000 ; move all towers to the high end stopping at the endstops

    G1 H2 X-5 Y-5 Z-5 F3600 ; go down a few mm

    G90 ; absolute positioning

    M104 S245 ; Set Extruder Temperature

    M190 S85 ; Set bed temp and wait to reach target temp

    M109 S245 ; in case extruder still isn't to temp set and wait.

    ;

    ; *** Main G-code ***

    ;

    ; BEGIN_LAYER_OBJECT z=0.250 z_thickness=0.250

    ;

    ; *** Selecting and Warming Extruder 1 to 245 C ***

    ; Head to the start of the next path

    G1 X17.315 Y5.420 F6000

    When you execute that last G1 command, the effector is only 5mm below the top. So it can't move far in XY without one of the carriages hitting the stop. You need to move to a low Z value either in that line or before it.

    In the startup code for my delta, I move to the edge of the bed at 5mm height before heating the extruder, so that any nozzle drool ends up on the edge not the centre.



  • G28 did not work:

    Error: Push(): stack overflow
    Error: Homing failed
    Error: G0/G1: insufficient axes homed

    @dc42 David I'm not completely clear on your comments. Are those the exact changes I should make or are they where I have a problem? I'm quite inexperienced in this in case you hadn't already been shaking your head in dismay.



  • @dc42 OK. I've found it and have almost solved it. Just a bit more tuning and back to the more important issue of printing. Thank you (and @phaedrux) for your help.


Log in to reply