Broken duex5 or fixable? / Panel Due not connecting



  • Hello 🙂

    Ive got a railcore and it could be that i grilled my duex5. I connected it reversed polarity and now its not booting.

    Things ive checked:
    M115 in dwc doesnt show a duex5 is connected.
    Tried it with 5v to test, no movements.
    Corrected the polarity
    Checked the fuses. They are all good.

    I ordered a 40pin cable to test it but need to wait until it arrives.

    Anyone had a same situation or has an idea what i could do next?

    Secound topic:

    The paneldue7i that i got isnt connecting to the machine. I haave the newest firmware and in the config.g its enabled. Connected it with a 10 pin on the correct slot ob the duetwifi. Baudrate is equal.

    In the right top spot it only shows connecting but never change to idle.

    What can i do here ?

    Greetings and have a good day.
    Chris



  • @3DMakerHub said in Broken duex5 or fixable? / Panel Due not connecting:

    I connected it reversed polarity and now its not booting.

    it should have some reverse polarity protection, but nothing is perfect. If you have a multimeter you could try testing D6 on the Duex board to see if it failed.

    @3DMakerHub said in Broken duex5 or fixable? / Panel Due not connecting:

    I ordered a 40pin cable to test it but need to wait until it arrives.

    40?

    @3DMakerHub said in Broken duex5 or fixable? / Panel Due not connecting:

    Connected it with a 10 pin on the correct slot ob the duetwifi. Baudrate is equal.

    does it work with the 4 pin connection instead? how long is the 10 pin cable?



  • Thanks for your reply.

    1. I can measure it and will report back.

    2. The 40pin cable to connect the duetwifi to the duex5.

    3. i tried to connect it via the 4 pin cable and got the same effect. The 10 pin cable is about 15-20 cm long.

    Greetings



  • you will have more success if you use a 50 pin cable 😉



  • @3DMakerHub said in Broken duex5 or fixable? / Panel Due not connecting:

    i tried to connect it via the 4 pin cable and got the same effect. The 10 pin cable is about 15-20 cm long.

    see https://forum.duet3d.com/post/134957

    also

    If you have a USB-TTL adapter (with 3.3v I/O!) you can connect try talking to the Duet and PanelDue individually to try and narrow down which side isn't doing their job.

    PanelDue should send M408 S0 regularly (i think). The Duet should respond if you send it the same code, but you will have to send M575 P1 S0 (or possibly M575 P1 B57600 S0) to the Duet (via usb or web first to disable the checkum checking to get a response.



  • Hi,

    now i got time to do some tests. I think the duex is not broken. when i measure between black vin on the duex and the motor pins i have about 7v. also the bl touch is working. What could be the problem ?

    BTW i fixes the problem with the paneldue 🙂 thx for this.


  • administrators

    @3DMakerHub said in Broken duex5 or fixable? / Panel Due not connecting:

    M115 in dwc doesnt show a duex5 is connected.

    If M115 still doesn't show that a DueX5 is connected, here are some possibilities:

    1. 3.3V is not getting through to the DueX, perhaps because of a faulty ribbon cable. Test this by measuring the voltage between the +3.3V and GND pins on the 10-pin DueX5 expansion header.
    2. The SX1509B chip is not responding to I2C requests from the Duet. This could be because the chip has failed, or there is a bad solder joint under the chip, or again a faulty ribbon cable.


  • @dc42

    Thx for this idea. I turned on ac and measured on the 10 pin expansion pins on the duex. i get 3.3V like it should be.

    Its nearly impossible to get the 50 pin ribbon cable here in switzerland or even in the eu. Dont wanna buy a duex extra only for the ribbon cable.


Log in to reply