Adding 11th and 12th extruders (Repost)



  • I'm re-posting this under general discussion because I haven't gotten an answer from the firmware installation subforum.
    I'm building a multi extruder machine with tool switching. I successfully set up a duet wifi with a duex5 expansion board but I would like at least one or two more extruders. I know from reading that it is possible to hook up two external stepper drivers to the CONN_LCD pins on the duet 2 wifi and have figured out the hardware wiring from a previous forum posting. The only issue I have now is how to add them in the reprap firmware. I'm unable to add any more additional extruders through the configurator web tool. I tried simply manually changing the config.g file to two extra defined drives and that created a visual change in the DWC of adding two extra selectable drives in the Tools section of settings which I could click on. However whenever I try to create tool I get an error message that says "bad drive selection". Is there a hard-set limit to how many extruder drivers can be configured in the reprap firmware and if so is there any way around this? Does anyone have experience creating their own custom firmware?



  • You might want to look into the Duet3 board. I don't really know much about it but since nobody has replied yet I thought I might give you a hint in the (possibly) right direction. The Duet3 features CAN bus where you can connect up to 24 stepper motors (see https://www.duet3d.com/Duet3Mainboard6HC).
    You might also check this interview with Anthony from Duet3D at TCT2019: https://www.youtube.com/watch?v=W6U-u0wBdfQ
    As I said, I can't really answer specific questions about this topic but maybe it still helps 🙂


  • administrators

    You will need to use M584 to declare all the extruders, after that you should be able to use them in M563 commands. What M584 command did you use, and what M563 commands are failing? Which firmware version are you using?


  • Moderator

    @usescoasters please don’t post duplicate threads. It makes supporting you more difficult.

    Original thread: https://forum.duet3d.com/topic/14897/adding-two-custom-extruders-to-reprap-firmware-and-dwc?_=1584099788778

    Ian



  • Thanks for the advice! Sorry about the repost. However my problem seems to have mysteriously solved itself over night after restarting my duet. Now the user interface seems to register the changes I made to the config.g file (which, for the record, did have the M584 command line changed to add additional drives). Also, according to the web ui my firmware was 2.0(RTOS) (2018-06-05b3).


  • administrators

    @usescoasters said in Adding 11th and 12th extruders (Repost):

    Also, according to the web ui my firmware was 2.0(RTOS) (2018-06-05b3).

    That's rather old, so I recommend you upgrade to a more recent version such as 2.05.1. Read the upgrade notes first, including the ones for the versions you skipped.


Log in to reply