PanelDue 5i V1.0 - White screen of death?



  • I purchased a PanelDue 5i a few weeks ago and had it connected to my Duet2Wifi with the ribbon cable. It was working, but today when I turned on the printer it was just a white screen. I tried following the directions here without success. Windows sees the Bossa port without any issue, however when I run the Bossa app or command line, it tells me it cannot connect to the port. I've tried several cables and two computers. Another issue is that the PanelDue does not reset. Pressing and holding the erase button and then pressing the reset button doesn't change anything - just white screen. Is it dead or am I missing something?



  • @pkirill said in PanelDue 5i V1.0 - White screen of death?:

    Windows sees the Bossa port without any issue, however when I run the Bossa app or command line, it tells me it cannot connect to the port.

    Maybe try to open the port in another terminal software (Yat, RealTerm, Putty, whatever) just to rule out another program using the port?


  • Moderator

    Are either of the buttons stuck down?


  • administrators

    @pkirill said in PanelDue 5i V1.0 - White screen of death?:

    Windows sees the Bossa port without any issue, however when I run the Bossa app or command line, it tells me it cannot connect to the port.

    Are you sure you are using the correct version of Bossa? 1.9-2 is current. Some older versions don't recognise the SAM4S processor that PanelDue uses.



  • So a few reboots later, I was able to get it to connect. (I did try YAT and Putty with the same results - but thanks for that suggestion! and using BOSSA 1.9.1 which came from the wiki...) I think the trick was to plug it in, have windows recognize it, then reboot with it still connected. I was finally able to flash the firmware and got the screen and buttons back. BUT...

    Now I have a calibration issue (at least I think it's calibration). It's like the touch is shifted down and right. If I try to touch the stop button or control button for example, there is no response. If I touch the console button, the stop button is pressed. If I touch the setup button, I get the temp set button bar...

    I read there was supposed top be a calibration tool but if I can't get to the setup button is there another way to get to it?



  • I've always been able to aim off the buttons to get to the calibration; do you have a case for the PanelDue that may be exerting pressure on the edge of the screen?



  • no case at all at the moment... I made a video of what it's doing here: PanelDue51- Touch Offset


  • Moderator

    After a firmware update the first thing that comes up is the calibration routine. So maybe try flashing it again so you can redo calibration.



  • @Phaedrux Yup - flashed it at least a dozen times using PanelDue-5.0i-7.0i.bin
    v 1.23.2. After the flash, it remains white, pressing reset doesn't change it. So I power off and and back on, then I get the splash screen and it rolls into the main screen. No calibration, still offset...


  • Moderator

    Do you mean Erase and then reset?



  • @Phaedrux Yes - With it connected to the PC via USB, I press erase for a few seconds and then reset. Nothing visibly changes, but if I unplug the USB power and plug it back in, the screen comes up white and it will accept a write from BOSSA 1.9.1. Write reports success. Verify reports success. Info returns Device: ATSAM4S4, Version: v1.13 RC2 Feb 20 2013 13:25:17 (not sure what that's referring to, though). Now if I press the reset button, the Duet3D splash screen rolls up, then immediately to the main screen. No calibration option...



  • Are you certain you check the "erase" box in bossa?

    ATSAM4S4, Version: v1.13 RC2 Feb 20 2013 13:25:17 (not sure what that's referring to, though).

    probably the bootloader version, shouldn't matter.



  • @bearer Yes - Erase all, Lock, Boot to Flash are checked while performing the above steps.



  • idk, i've always opted for the command line version, i think the options are different and it allows automatic reboot avoiding any issues there. might be worth a try. Assuming windows and normal english paths; with firmware in download folder and bossa in program files for 32bits programs.

    cd Downloads
    "\Program Files (x86)\BOSSA\bossac.exe" -e -w -v -b PanelDue-5.0i-7.0i.bin -R
    


  • @bearer Thanks for that - just ran command line as you showed it (had to add -p COM5) and it flashed and rebooted. Same result, touch is off, no calibration option. 😞



  • @pkirill said in PanelDue 5i V1.0 - White screen of death?:

    touch is off

    but if you know where you're tapping and you see where it hits, can you not extrapolate where to tap to hit setup and then calibrate?



  • @bearer It's waaayyyy off - I think I'd need a few more inches of screen. 🙂 if tap in the very lowest right part of the screen, I get the button bar (-5 -1 SET +1 +5) for setting the bed temp and trying to tap that just activate the stop button and clears it.

    Its almost like the resolution of the touch area has been giant sized and moved. There is a large area on the lower part of the screen I can tap that activates the stop button and much across the top that activates nothing.


  • Moderator

    Can you do a test for me to confirm that it's actually flashing?

    Use the nologo version of the firmware. Then when it boots up there should be no splash screen. If the splash screen remains then we know it hasn't actually flashed.



  • Done. Flash using no logo firmware and no logo on reset. No calibration... So it is actually flashing... I've also checked the solder on the four wires from the LCD and verified the ribbon cable is seated...


  • Moderator

    Can you post some detail photos of the front and back of the paneldue?

    Does it look like the screen is too tight, or skewed, or depressed in anyway? I wonder if maybe something is causing a false touch on the display so that after flashing, the touch calibration (that white screen you describe) is being completed accidentally.



  • @Phaedrux ! Thanks for you continued help with this. I couldn't upload them all here, but here's a link to a gallery of images: PanelDue 5i Images

    I don't see any depressions, cracks, dents, etc. but not really sure what I'm looking for...


  • administrators

    To run calibration:

    • Are you able to get to the Setup page and select either the Calibrate Touch or the Factory Settings option? This depends on just how far out the calibration is.
    • If you can't do that, here's a trick to force it to go to the calibration screen at startup. Press Erase and load Bossa, but upload the wrong firmware file (just make sure it is for a v3 PanelDue, not a v2). Then press Reset to start that firmware. The screen may be garbled, but wait for the splash screen to disappear. You should now get a (possibly garbled) touch calibration screen. At this point, press Erase again and upload the correct firmware. The touch calibration screen should appear after startup.

    Explanation: on a V3 PanelDue, upgrading the firmware to a later version of the same build doesn't clear the touch calibration; but uploading a different firmware build does.


  • Moderator

    @dc42 could you also downgrade to an older version of the correct firmware, then upgrade?

    Ian


  • administrators

    @droftarts said in PanelDue 5i V1.0 - White screen of death?:

    @dc42 could you also downgrade to an older version of the correct firmware, then upgrade?

    Ian

    Only a very much older version of the firmware.



  • @dc42
    "Are you able to get to the Setup page and select either the Calibrate Touch or the Factory Settings option? This depends on just how far out the calibration is."
    No luck at all getting to the Setup page. Tapping lowest rightest corner of the screen with a pencil lead only gets me to the heated bed temp area next to Standby C.

    I was very hopeful - the explanation made total sense. However, flashing with v3 firmware did not get it. I did notice more of a pause at the end of the splash rollup but still no calibration. The closest I got to a real change was flashing with the PanelDue-v3-7.0.bin left me with no touch action after a button reset and reflash with PanelDue-5.0i-7.0i.bin. I tried the 4.3 and 5 as well. All gave a calibration screen (garbled in some way as you said). But after a reset/reflash either the same issue or no touch. Tried all using the BOSSA GUI and command line, different COM ports and USB cables...


Log in to reply