Waaaaaay too slow



  • Got it. will do in just a bit



  • Here's my config file.

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Mon Mar 09 2020 20:36:41 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Printrbot Afterburner" ; set printer name
    M551 P"bruh" ; Machine password (used when you connect Duet Web Control or via FTP)

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X100.00 Y100.00 Z80.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X100.00 Y100.00 Z5.00 E250.00 ; set accelerations (mm/s^2)
    M906 X1500 Y1500 Z1500 E1500 I60 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X230 Y210 Z200 S0 ; set axis maxima

    ; Endstops
    M574 X2 Y1 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M558 P5 I1 E0 S0 H2.5 F20 T15 ; set Z probe type to inductive and normally open the dive height + speeds
    G31 P1000 X0 Y0 Z0 ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M140 H-1 ; disable heated bed
    M305 P1 B4725 C7.06e-8 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 0 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P1 D0 H1 F0 S"Print Head" ; define tool 1
    G10 P0 X0 Y0 Z0 ; set tool 1 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • @Super_Sonic_7036 said in Waaaaaay too slow:

    M203 X100.00 Y100.00 Z80.00 E1200.00 ; set maximum speeds (mm/min)

    these are in mm/min not mm/s as maril or other have, could maybe explain your issue?


  • Moderator

    @Super_Sonic_7036 said in Waaaaaay too slow:

    M558 P5 I1 E0 S0 H2.5 F20 T15

    Your F and T values are used for probing and travelling between points. They are set in mm/min, so you have them set to basically a standstill.

    Try F200 and T6000



  • Thanks, I'll try that now.


  • Moderator

    @Super_Sonic_7036 said in Waaaaaay too slow:

    M92 X80.00 Y80.00 Z4000.00 E420.00 ; set steps per mm

    Are you sure your Z steps per mm are 4000? That's the default used by the configurator, but chances are it's not right for your setup.

    How is your Z axis setup?

    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X100.00 Y100.00 Z80.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X100.00 Y100.00 Z5.00 E250.00 ; set accelerations (mm/s^2)

    Bearers comment goes for the other speed settings too. Your values are very conservative. You will have to do some testing, but they could all likely be increased by a factor of 10.



  • My Z-axis has been running fine, but I'll consider changing that if I see too it. Thanks for the concern.



  • And if anyone is wondering, I'm using a Printrbot Simple Pro bare-bones kit, so if you have any suggestions, feel free to tell me.



  • Update:

    My mesh bed probing is moving at a much more desirable speed, thanks!



  • @Phaedrux
    I took your suggestions into account as far as speed goes. I added a zero to the values that I thought could go faster, and my machine is now running at an even better pace. However, I had to reduce the acceleration and speed values of my extruder, as it was moving to fast, and it never properly gripped the filament. I'm still testing things as far as it goes, but so far, things are moving better.


Log in to reply