SD Card reader not working



  • Hi,
    I have a problem with my SD card slot on my duet 2 wifi.

    Im certain its the reader and not the card because:

    1. Ive tried multiple cards
    2. If I plug one of the same cards into the Panel 7i it reads the card no problem.

    I have tried with Stepper motors and limit switches plugged in and out and nothing seems to be working. I have unplugged everything from the board except the USB cable going to my PC for YAT and still nothing on the SD reader.

    Any suggestions or is this a warranty claim?



  • While I can't answer for the Duet people, it definitviely sounds like the reader is bad. If you add a clear and focused picture of the rear of the SD card reader, showing the solder joints you'll probably speed up the process when the admins drop by.


  • Moderator

    @GT1Za As your SD cards work in the PanelDue, it does rather look like it's a board problem.

    Can you turn on the Duet with just USB power with an SD card inserted, and send (via YAT) M122 to the Duet? Then copy and paste the response into your reply here. This should show what the firmware thinks is going on with the SD card socket. See https://duet3d.dozuki.com/Wiki/SD_Card#Section_Troubleshooting_SD_Card_issues to diagnose this.

    Also check if anything is getting hot. The SD card holder, the main processor and the WiFi module (a short circuit in your wiring usually causes these to be damaged first).

    Then, please post a good, in focus, high resolution picture of your whole board. If possible, also take a picture of the back of the SD card socket, where the pins are soldered to the PCB; this is an example of a poorly soldered SD card socket:

    abac229d-e0c6-42e4-8292-c9b0120f7b1e-image.png

    Ian



  • @droftarts
    see pics below:
    2.jpg 1.jpg

    I dont get anything back from M112 while an SD card is plugged in. The whole system just seems to be hung. On the Panel 7i it just says connecting. Eventually I get an error message on the 7i that says the SD card is not readable but no response from M122

    If I unplug the SD card i get:

    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.05.1 running on Duet WiFi 1.02 or later
    Board ID: 08DGM-917DA-G4MS8-6JKD4-3SN6S-1TVV8
    Used output buffers: 1 of 24 (1 max)
    === RTOS ===
    Static ram: 25712
    Dynamic ram: 92704 of which 0 recycled
    Exception stack ram used: 248
    Never used ram: 12408
    Tasks: NETWORK(ready,1876) HEAT(blocked,1324) MAIN(running,4748) IDLE(ready,160)
    Owned mutexes:
    === Platform ===
    Last reset 00:00:15 ago, cause: power up
    Last software reset time unknown, reason: Watchdog timeout, spinning module Platform, available RAM 11996 bytes (slot 1)
    Software reset code 0x0050 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0443380f BFAR 0xe000ed38 SP 0x200049ec Task 0x4e49414d
    Stack: 004463c7 0044a53a a1000000 476a6000 3f000000 3edb6db7 b7b4d800 3331bb4c 40000000 3f317200 b5ddea0e 388aa908 bb35fe81 3c4192f5 3f800000 c00704ca 3d56a81c 4b000000 476a6000 20000010 200055b0 200055b0 80000000
    Error status: 0
    Free file entries: 10
    SD card 0 not detected, interface speed: 30.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 33.1, current 34.4, max 34.5
    Supply voltage: min 1.6, current 1.7, max 1.9, under voltage events: 0, over voltage events: 0, power good: no
    Driver 0: ok, SG min/max not available
    Driver 1: ok, SG min/max not available
    Driver 2: ok, SG min/max not available
    Driver 3: ok, SG min/max not available
    Driver 4: ok, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 17846726
    Slowest loop: 0.14ms; fastest: 0.06ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Move ===
    Hiccups: 0, FreeDm: 160, MinFreeDm: 160, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === DDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 0 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 0.14ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8
    - WiFi -
    Network state is disabled
    WiFi module is disabled
    Failed messages: pending 2779096485, notready 2779096485, noresp 2779096485
    Socket states: 0 0 0 0 0 0 0 0
    ok
    

  • Moderator

    @GT1Za (Sorry, edited your post to make the M122 more readable!)

    SD card 0 not detected, interface speed: 30.0MBytes/sec
    That's kind of odd. It usually reads 20.0MBystes/sec.

    Unfortunately, I can't really make anything out from your pictures, because the lighting is from the side. I can see that the SD card socket looks okay, probably, because the two main feet each side of the pins look flat against the PCB. Can you take a picture with less side light?

    Ian



  • @droftarts
    sorry are you looking for one of the whole PCB or just the SD reader?


  • Moderator

    @GT1Za Both, really. There's no light on the back of the SD card socket, and there's no light on the top of the ICs to see if any of them are burnt out.

    Ian



  • @droftarts
    ok ive tried taking one with a flash, let me know if thats any better. Unfortunately the lightning is terrible in my house. I had to resize the images due to the restriction of max 4mb file for the site.

    20200324_174803_resized.jpg 20200324_174754_resized.jpg


  • Moderator

    @GT1Za Hard to say, still a bit dark! But this doesn't look ideal.
    01cdbdd3-e356-489a-ba78-d57eed83a010-image.png
    U2 and U3 look okay. I've asked @dc42 to take a look, see if he can see anything.

    Ian



  • @droftarts I'm not to sure of what you're looking at, but if you're more specific I can try get a better pic?


  • Moderator

    @GT1Za Probably good enough of the SD card socket, but a better picture of this area would be good (this is a bit blurry):
    cae69d2b-16c0-4932-ae8c-b18847a03d5a-image.png

    If running on USB power only, it's quite possible that there's not enough power to turn on the Duet and the PanelDue. Disconnect the PanelDue, and do all troubleshooting via YAT on a PC connected on USB.

    Has the SD card socket ever worked? I also notice from M122 that the WiFi is disabled. You can enable it using YAT, even without the SD card. Have you tried that?

    And is anything getting hot? SD card socket, processor, WiFi module. Touch with your finger.

    Regarding warranty, our warranty is 6 months from the date of purchase, assuming you bought it through us or one of our suppliers. Follow their warranty process, but usually they'll ask us for warranty approval, which is done here on the forum, once we confirm this is a component failure due to manufacturing fault.

    Ian



  • @droftarts I did enable the wifi through YAT but it doesn't seem to be holding it. Every time you power down it seems to lose the information.
    If you try login through the wifi, you just get an error that the www folder isn't on the SD card.

    It is still within the warranty period and ill put in the claim tomorrow. I'm not to sure how we will sort it out as I believe the UK is in lockdown and so is South Africa (where I'm from) so I don't see a way of shipping. Do I need to send this board back to Duet, or do they just ship a new one on your guys recommendations?

    I'll wait till its light tomorrow and try get some better pics of the board.

    Thanks


  • Moderator

    @GT1Za said in SD Card reader not working:

    I did enable the wifi through YAT but it doesn't seem to be holding it. Every time you power down it seems to lose the information.

    That's expected, because the command to turn on the wifi is stored in the config.g file... on the SD card!

    Has the SD card socket ever worked, as far as you are aware? Was the machine working, but this fault developed? Or is this a new Duet/installation?

    Ian



  • @droftarts it did work. But I've only switched it on for config (mainly to get the BL touch working). So maybe 3 or 4 times.

    Then did some cable management around the frame (literally just putting some cable ties on) and then when I switched on for final tests nothing worked.

    It was weird because no wiring had changed, so I doubt it was anything there. There was no smell of anything burning or anything being overly hot etc.



  • @dc42 @droftarts
    Here are some new pics and I think are as good as they are going to get. If there are specific areas you want to see I can obviously take of those.
    20200325_093753_resized.jpg 20200325_093436_resized.jpg

    There is a shadow on the 5th pin of the SD card (from the left) that makes it look broken, but I have put it under a magnifying glass to check and it is connected. I can email you the high res photo where if you zoom in you can see its fine. Please provide me an email address or a way to give you a 10MB file if you want this?


  • administrators

    Hi @GT1Za, thanks for your patience. I approve a warranty replacement for your Duet. Please contact your supplier.



  • @dc42 thanks!
    Roland has gotten in contact with me.

    On a side note, VERY impressed with the responsiveness of both yourself and @droftarts as well as the warranty department. I only filled in the form an hour or 2 ago!
    Well done guys, this is how you build an amazing brand


  • administrators

    We're pleased to help! I'm sorry your board developed a fault. For info, we've seen issues with poor soldering on the right hand pins of the SD card socket before, which is why I evaluated a more expensive but compatible socket recently. I'm please to say that I found that the pins on that socket are much more wettable by the solder, so we've switched to it for future production.


Log in to reply