Problem with extruder settings



  • I calibrated the extruders steps per mm by drawing a marking on the filament and extrude 5 mm from the g-console and measuring and adjust the steps per mm until it got right. But when i start a print the extruder spins way to fast and blocks it get blocked between the nozzle and bed.

    When i extrude with g-code from the console the settings is 1100 steps per mm, but when printing i had to lower it to 0.076 for it not to over extrude.

    Cant figure out what it can be.



  • 5mm is way too small an amount of filament to be able to set the steps per mm accurately. As a general rule, 100mm or more will give you more accurate results. 1100 steps per mm seems very high unless you have very high gearing. My E3d titans with 3:1 gearing use around 416 steps per mm, my old Mendel with 5:1 gearing used around 630 steps per mm which would indicate your steps per mm would be correct if you had about 10:1 gearing. What method did you use to set the steps per mm (apart from only extruding 5mm)?



  • I calibrated it when printing and then i hade to set it as low as 0.076 for it not to over extrude.
    But i found that strange and decided to do the extruder calibration from the beginning, before that i had found 115 steps per mm extruded the correct amount, both 5 mm and 100 mm.
    So i dont understand how it can differ so much.

    I tried now with 100 mm again and if the steps per mm is higher than 30 it starts to slip.
    But i think it needs to be higher, because it just extrudes 34 mm filament with that setting.

    Another strange thing is that when printing it goes very slow, even though i have raised the acceleration to 8000.



  • Ok now i set it to 93 steps per mm and a max speed of 25 mm/s, and now it extrudes exactly 100 mm filament when extruding only 1 mm/s.
    This is from the original settings.

    But when printing the heads moves very slowly and the extruders spins to fast for it.

    Why would the extruder move faster and the head slower when printing than when moved from the console?


  • administrators

    Assuming a 0.4mm nozzle, your extruder needs to be able to manage at least 5mm/sec without skipping steps, in order to print at reasonable speeds.



  • Could be a slicer problem, like having the wrong filament diameter set.



  • I have the same Slicer settings as i did before changing to Duet and then it did work fine and when printing the speed on the extruder is to fast by a factor of 100 or more, but the xy-axis moves slower than it should.
    Seems like the speed for extruder is multiplied by some big number or the speed on xy-axis is by i small number.

    I did test G1 E100 F300 now and the extruder slips on the filament, but i think that is strange since i did print fine before and it could print fast without problem

    My stepper settings now and max speeds are exact same as it was on the old controller card, so that shouldn't be the problem.



  • Ok found something.
    The config.gcode had M83 in the beginning so the printer was in relative move for extruders while the slicer do it in absolute mode.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.