IDEX Homing Issues



  • I am using Duet 3 on RRF 3. When I select T0 and used G28, the finished position is X-30 and U320 which is the value I want. However, when I select T1 and use G28, the final position is X30 U30 which will crash the machine. The goal is to set the position to X320 and U320 when G28 is used with T1 selected.
    I don't want to add a T0 in the homeall.g because this will turn off the heater at T1
    Here are my printer dimensions:

    ; Axis Limits
    M208 X-30 U30 Y0 Z0 S1                                ; set axis minima
    M208 X260 U320 Y200 Z180 S0                          ; set axis maxima
    

    Here is the homex.g

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sat Mar 28 2020 16:58:00 GMT-0500 (Central Daylight Time)
    G91               ; relative positioning
    G1 H2 Z5 F6000    ; lift Z relative to current position
    G1 H1 X-295 F3000 ; move quickly to X axis endstop and stop there (first pass)
    G1 H2 Z-5 F6000   ; lower Z again
    G90               ; absolute positioning
    
    

    Here is the homeu.g

    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sat Mar 28 2020 16:58:00 GMT-0500 (Central Daylight Time)
    G91               ; relative positioning
    G1 H2 Z5 F6000    ; lift Z relative to current position
    G1 H1 U330 F3000 ; move quickly to X axis endstop and stop there (first pass)
    G1 H2 Z-5 F6000   ; lower Z again
    G90               ; absolute positioning
    

    And here is the homeall.g

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sat Mar 28 2020 16:58:00 GMT-0500 (Central Daylight Time)
    G91                     ; relative positioning
    G1 H2 Z5 F6000          ; lift Z relative to current position
    G1 H1 X-295 U325 F3000 ; move quickly to X and Y axis endstops and stop there (first pass)
    G92 U320
    G1 H1 Y205 F4000 ; move quickly to X and Y axis endstops and stop there (first pass)
    G92 Y200 
    G90                     ; absolute positioning
    G1 H2 X120 Y100 F6000        ; go to first bed probe point and home Z
    G30                     ; home Z by probing the bed
    
    ; Uncomment the following lines to lift Z after probing
    ;G91                    ; relative positioning
    ;G1 Z5 F100             ; lift Z relative to current position
    ;G90                    ; absolute positioning
    


  • Here is the intended position, when I select T0 then G28:
    ead7a155-5216-468a-baa9-c052c5e871ea-image.png
    However, when I select T1 and then G28:
    5aef77ab-c570-43d8-9f53-59fe298bc6de-image.png
    In this case, although the U axis is at 320mm, the firmware thinks it is at 30.


  • administrators

    Did you resolve this?

    The G92 commands in your homeall.g file are not needed and should be removed.



  • Hi, I later found out that it was in my config.g file while I configured the end-stop setting wrong. The U axis endstop is set to minimum where in reality it should be homing to the maximum. Thanks for the follow-up.


Log in to reply