Duet not extruding on x axis and panel due has no screen



  • My duet wifi has suddenly gone mad for some reason if I try to print it extrudes fine but as soon as it goes accord the x axis on the bed it stops and even more strange it will print a cube just fine but anything else is unprintable it was running fine before all this I've reinstalled the firmware and rolled the firmware back and forward and nothing does the same my panel due screen also stopped working if u press the buttons it makes the noise but no display what so ever I have rest the firmware on it as well and same issue I'm not sure what to do i replaced the motor and same issue and all axis move freely all voltages were tested and ok I'm lost from here any help would be appreciated btw I checked all connections an pins they seem fine As well



  • Just to clarify, the printer currently prints a calibration cube OK? Is that correct?



  • Yes I tried a cube and it did print but anything else the extruder just stops completely when it gets to the pass on an x axis sometimes it looks like the extruder pulses when it gets there sometimes it just doesn't do anything I've tried known good files to print from both s3d and cura with no dice exactly the same with or without retactions is the same speed doesn't make a difference I'm at a loss


  • administrators

    Have you checked that the SD card hasn't become corrupted?



  • That I have not I will pick up a new one when I leave class in just a bit and try it out and post back the findings again I truly appreciate that fast help you guys are awesome



  • Ok so I picked up some new sd cards and reinstalled all the firmware uploaded a couple pints to them and it will still print a cube just fine but anything else the extruder will still stop extruding on The x axis no matter what settings I try it doesn't change



  • Any chance you could make a video of it happening? As a cube has X axis moves, I'm struggling to imagine what the problem looks like.



  • Of course I'm at work at the moment but I get off a little early today I will start a print and show you what is happening I know it's weird I'm struggling to figure it out to I thought the same thing if it prints a cube it in theory should print anything else but I will take that video as soon as I get home and you can see exactly what's happening


  • administrators

    Were the cube and the other prints you are trying to do sliced using the exact same slicer settings? You could look at the first ~50 lines of gcode and see if you can spot any differences. Some possibile differences are:

    • a difference in extruder temperature
    • relative vs. absolute extrusion and/or missing M83 or M82 command


  • https://drive.google.com/file/d/0B6CzmHFanmGbMFctQ0dBZG9lSE0/view?usp=sharing

    i had to upload to my google drives there are not many files in there and the only two videos are the ones you want to see one is a print normally and the other is the same file without filament and hovering above the bed about 20 mm or so and on a side note the cube did the exact same thing to me now as the file in the videos and all the files i re downloaded and sliced in simplify3d with the exact same settings if i turned off retraction i did it for the other file as well and named the save file different from the previous so i knew which setting had been changed i also tried with the option in s3d for relative extrusion on and off and no change i have also included the gcode files in a folder named gcodes in the google drive as well one with relative and one with absolute and named as such so you may look over them in case you may see something i dont which is entirely possible im a modeler and digital artist not a gcode specialist or engineer or any thing like that but it appears correct to me but again you are much more versed on this than me lol again thanks deckingham and dc


  • administrators

    From the video, it appears to me that it's laying down filament at the back of the print, but not at the front. This is probably caused by the bed not being level. The bed is probably too high at the front, so the nozzle is touching the bed instead of being just above it, and the molten plastic can't get out.



  • Still difficult to tell from the video but I'd say David's assumption is probably correct. The fact that it has done a small cube near the centre of the bed, where the bed height probably doesn't vary that much ( due to the small size) would bear that out. The larger the object, the more any inaccuracies in bed level will show up. It may also just be a case of poor first layer adhesion by perhaps too low a bed temperature. In any case, I'd say it's almost definitely a mechanical issue.

    Ref the relative/absolute extrusion thing. Most people choose to use relative extrusion but it's not obligatory. The important thing is that the slicer and Duet are both set to the same. If the slicer is set to use relative extrusion, then you need to set the Duet to relative using M83 in your config.g. Conversely, if the slicer is set to absolute then you need to set Duet to absolute by using M82 (instead of M83).


  • administrators

    Preferably, include the M83 or M82 in your slicer start gcode, then it doesn't matter what the setting in config.g is.



  • I'll check the slicer code and see if it changes but for the bed level the second video is printed hovering 20mm off the bed doing the same issue so bed level wouldn't be a factor since it's not near the bed and there is no filament pushing thru the extruder but I'll reset my config g file and see if that was my issue all along



  • Also I couldn't get it to print the cube again that failed too


  • administrators

    If it's printing 20mm off the bed, then perhaps Z homing isn't always stopping at the correct height.

    I only saw a link to one video in your earlier post.



  • I re tried the m82 and m83 commands with the print head off the bed with resliced files and same thing extruder stops in same places



  • Like David, I saw the one video file. From your description, it's sounding like you have a bad connection on your extruder stepper motor wiring.



  • I have to go to work in a little bit but when I get home I will run a new stepped motor wire straight from the extruder to the duet bypassing the cable chain and see if it changes I have two extra connectors and extra pins from the original parts when I got the duet



  • Ok so I got home from work and completely removed the motor except for the extruder gear and ran a new jumper from the duet to the motor and it appeared to fix the issues as the gear seemed to run smooth so I guess I'm gonna delete my cable chain altogether because I'm assuming it pinched one of the coil wires I do really appreciate y'alls time helping me with my issue I know y'all are busy people and have always answered my questions super fast I constantly recommend this board to people on the forums I belong too and not just the product but your service behind it but one last question is it possible to run 2 wifi boards or would it be better to run the Ethernet version on the other I'm building a new build it's a long way off from electronics yet but I want to use a duet board on it ?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.