SOLVED Z Babystepping reverting after ~2 sec



  • I've been trying to run a large print of head straps for some of the new PPE that's been going around the 3D printing community, and because they're taking up the entirety of my almost 500mm x 500mm bed, I've found my bed probing to be a little less accurate than I'd like. Usually this wouldn't be a big deal, but my Z babystepping doesn't seem to be working (or holding I should say). During the print, if I send a babystep command, I can see my ballscrews rotate to compensate, but after about 2 sec, they rotate back by the same amount. I thought maybe I was just seeing the printer adjust for a change in the height map, but it is clearly doing this after any babystep command I send. If I send 4 babystepping commands, one after the other, I can watch as about 2 seconds later my Z axis hits ctrl+Z and undoes whatever adjustment I made. I thought maybe my motor idle time was set too low, and the motors were adjusting a step and then losing it due to a loss of power, but my idle time is set to 30 seconds, and even right after the controller reverts from the babystep I applied, I can see my ballscrews rotating ever so slightly due to mesh bed, so it can't be the motors going idle.

    Is anyone else having this problem? Is there some other line in my config that may be affecting this?

    Thank you in advanced!


  • Moderator

    Firmware versions?



  • @Phaedrux RRF 3.0, and all webserver related things were updated to the most recent version just a couple weeks ago.


  • Moderator

    You may want to update to 3.01 RC6 and DWC 2.1.1. I don't recall any baby stepping bugs but there has been a lot of work on RRF3 since 3.0



  • @Phaedrux Nope 😕 still doing it


  • Moderator

    How are you applying the baby stepping? DWC? PanelDue?



  • @Phaedrux DWC using the built in buttons. I don't have a PanelDue unfortunately.


  • Moderator

    Perhaps you are trying to babystep below the Z0 point.

    What are your axis minimums as defined in M208?

    You can alter your M208 Z value to be slightly negative so that you can baby step lower. M208 Z-1 for instance would let you go 1mm below what the firmware thinks is the probed height for Z0.

    Normally the firmware won't allow you to baby step below the first layer height. It's assuming Z0 is correct across the surface of the bed, but if the probe is a little off or the mesh grid isn't perfect. That could maybe explain why it's undoing your attempts to baby step lower?



  • @Phaedrux That's it! I did some more testing today and found that the babystepping works fine for a few steps, but starts undoing itself after the values become a bit more extreme (~200-300 microns). I didn't realize that the axis minimum still affected babystepping values. Thanks again for helping me diagnose!



  • I just want to chime in, had the same issue after adding bed levelers and getting my bed really flat.

    This created a new problem where Babystepping was "undoing" itself within 1-2 seconds. I could hold my hand on the Z rod and feel it bumping back. and watch the lines flatten out on the bed while printing, and then unflatten as it reset to Z=0.

    This totally solved it for me. I typically have to babystep -0.25 and now I can again.

    Thank you!


Log in to reply