extruder e steps doubled



  • I just changed extruder motors and my e steps doubled. Any ideas why that happened? Does it even matter?

    Here is my setup.
    firmware: Duet WiFi 1.0 or 1.01
    Firmware version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version 1.23
    Web interface Version 1.22.6

    Old motor: E3D Slimline stepper motor (0.9 deg)
    Bondtech BMG extruder
    Microstepping 16x
    e steps 840
    current 1400

    New motor: LDO pancake motor part number LDO-42STH25-140MAC (0.9 deg)
    Bondtech BMG extruder
    microstepping 16x
    e steps 1560
    current 1200

    I didn't change the wiring.

    It should have been a drop in replacement. I'm stumped why I needed to almost double my e steps.

    here is some of the config file

    ; Axis and motor configuration
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z3230 ; Set steps per mm
    M92 E1560 ; Set extruder steps/mm
    M201 X500 Y500 Z250 E600 ; Set accelerations (mm/s^2)
    M203 X10000 Y10000 Z200 E2000 ; Set maximum speeds (mm/min)
    M566 X200 Y200 Z20 E500 ; Set maximum instantaneous speed changes (mm/min)

    M906 X2600 Y2600 Z1500 E1200 I30 ; Set motor currents (mA) and motor idle factor in percent



  • I'll bet the new stepper is an 0.9 degree (400 steps/turn) instead of the more common 1.8 degree (200 steps/turn) motor.


  • Moderator

    Nope, doesn't make any sense. How did you arrive at the new value?

    I'd say the original was a 1.8 degree too, but 800 ish steps per mm for the bondtech would be correct for a 0.9.



  • Yea, it's weird. Both motors are 0.9 deg. Per Bondtech's website a 1.7 deg stepper motor should be around 415 steps/mm. I was at 840 for the old slimline motor which is a 0.9 deg stepper motor. That makes sense.
    Here is my process:
    -using PETG
    -set my extruder temp to 235°C
    -measured 100mm of filament and marked it
    -On the duet WiFi I opened the extrusion menu
    -selected 100mm
    -selected 5mm/sec
    -selected extrude
    -only 50mm was extruded
    -doubled the value and iterated until I was able to extrude 100mm

    The final e step value was 1560.

    Other than the fact that it's weird and I want to figure out WHY this is happening is there any negative impact to having the steps so high?


  • Moderator



  • Is it possible that the newer pancake motor has much less torque, and cannot reliably microstep to the same resolution? Try setting the E axis to 1/8 or 1/4 stepping.



  • If my calculation is correct, extruding 100mm with 1560 microsteps per mm, and 16x400 microsteps per revolution will result in

    100 * 1560/16/400 = 24.375 revolutions.

    Make a black mark on the stepper shaft and see if you count ~24 revolutions while extruding 100mm.



  • I finally figured it out. The grub screw on my bondtech extruder was loose. The stepper motor would spin shaft assembly but the drive gear would only turn sporadically. I put some locktite on the grubscrew, put it all back together and its working great and the E steps are the same as before! For future reference if you see the large gear spinning on the shaft assembly and are getting inconsistent sporadic extrusion check to see if a screw is loose.


Log in to reply