Mesh bed leveling gone wild!



  • Here is my G code M557 X10:160 Y10:175 S40 . It seemed to be working fine staying within the coordinates given. 2 days ago instead of starting at X10 it starts at X-22 and instead of starting at Y10 it is now Y0. BUT the mesh grid map show it staying within the G code settings. Reinstalled the firmware still no change. What am I missing? When I do a home all it stops at X100:Y100 perfectly. The web interface also reports the correct coordinates. I looked for offsets or anything else that may be causing it but I don't see it.



  • Here is my config.g

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed May 03 2017 10:36:50 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X-22 Y-6 Z0 S1 ; Set axis minima
    M208 X190 Y214.5 Z180 S0 ; Set axis maxima

    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Y1 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z1 H5 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P445 X32 Y0 Z1.28 ; Set Z probe trigger value, offset and trigger height
    M557 X10:160 Y10:175 S40 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation
    M92 X322 Y322 Z6400 E1260 ; Set steps per mm
    M566 X1000 Y1000 Z1000 E2500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X5000 Y5000 Z500 E2000 ; Set maximum speeds (mm/min)
    M201 X2000 Y2000 Z800 E2500 ; Set accelerations (mm/s^2)
    M906 X1800 Y1400 Z1800 E1400 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P1 X200
    ;M305 P0 T100000 B4725 C7.06e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4317 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    ;M305 P2 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    ;M301 H1 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 0
    ;M301 H2 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 1
    ;M570 S120 ; Increase to allow extra heating time if needed

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 ; Set machine name
    M551 ; Set password
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H0:1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured
    M501



  • Can you show us your bed.g and config-override.g?



  • config-override.g

    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A152.9 C689.2 D1.0 S1.00 B0
    M307 H1 A368.4 C182.0 D2.5 S1.00 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 B0
    M307 H3 A340.0 C140.0 D5.5 S1.00 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 B0
    ; Z probe parameters
    G31 T1 P445 X32.0 Y0.0 Z1.28
    G31 T3 P500 X0.0 Y0.0 Z0.70
    G31 T4 P500 X0.0 Y0.0 Z0.00

    bed.g

    test



  • Just deleted the bed.g and config-override.g. Now it starts the mesh bed leveling at X-2 but still does not go past X98. Looked at the config.json and it does not match. Could this be the issue? If so do I edit it to match? It also thinks the firmware is 1.17 and I have 1.18.1

    {"board":"duetwifi10","firmware":1.17,"compatibility":2,"nvram":false,"geometry":{"type":"cartesian","mins":[0,0,0],"maxes":[200,200,180]},"drives":[{"direction":0,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":320,"instant_dv":15,"max_speed":6000,"acceleration":500,"current":800,"driver":0,"endstop_type":1,"endstop_location":1},{"direction":0,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":320,"instant_dv":15,"max_speed":6000,"acceleration":20,"current":800,"driver":1,"endstop_type":1,"endstop_location":1},{"direction":1,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":10240,"instant_dv":0.2,"max_speed":150,"acceleration":250,"current":800,"driver":2,"endstop_type":3,"endstop_location":1},{"direction":1,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":420,"instant_dv":2,"max_speed":20,"acceleration":250,"current":800,"driver":3}],"idle":{"used":true,"factor":30,"timeout":30},"homing_speed_fast":"30","homing_speed_slow":"6","travel_speed":100,"z_dive_height":5,"slow_homing":false,"probe":{"type":"unmodulated","trigger_height":2.5,"trigger_value":443,"x_offset":0,"y_offset":0,"speed":2,"deploy":false,"points":[{"x":30,"y":15,"z":0},{"x":30,"y":180,"z":0},{"x":180,"y":180,"z":0},{"x":180,"y":15,"z":0},{"x":100,"y":100,"z":0}]},"num_nozzles":1,"bed_is_nozzle":false,"bed":{"present":true,"heater":0,"use_pid":false,"width":200,"length":200},"chamber":{"present":false},"max_heater_temperature":260,"heaters":[{"scale_factor":100,"series":4700,"thermistor":100000,"beta":4138,"a":0.0005717725,"b":0.0002416626,"c":0,"channel":0},{"scale_factor":100,"series":4700,"thermistor":100000,"beta":4138,"a":0.0005717725,"b":0.0002416626,"c":0,"channel":1}],"toolchange_wait_for_temperatures":true,"generate_t_code":false,"tools":[{"number":0,"extruders":[0],"heaters":[1],"x_offset":0,"y_offset":0,"z_offset":0}],"compensation_x_offset":15,"compensation_y_offset":15,"mesh":{"x_min":30,"x_max":185,"y_min":15,"y_max":185,"spacing":20},"home_first":false,"orthogonal":{"compensation":false},"network":{"enabled":true,"name":"","password":"","dhcp":true},"fans":[{"value":"30","inverted":false,"frequency":500,"thermostatic":false},{"value":"100","inverted":false,"frequency":500,"thermostatic":true,"heaters":[0,1],"trigger_temperature":45},{"value":"100","inverted":false,"frequency":500,"thermostatic":true,"heaters":[1],"trigger_temperature":45}],"custom_settings":""}



  • Just changed to M557 X10:200 Y10:200 S20. Now it goes to X165 and the Web interface mesh display on show 1 row of coordinates at X190 here is my heightmap.csv . Does anyone have any ideas? I getting ready to pull out the SLEDGEOMATIC!

    RepRapFirmware height map file v1 generated at 2017-04-19 09:36 mean error -0.09 deviation 0.16
    xmin xmax ymin ymax radius spacing xnum ynum
    10 200 10 200 -1 20 10 10
    0 -0.204 -0.179 -0.162 -0.152 -0.152 -0.162 -0.177 -0.202 -0.222
    0 -0.112 -0.095 -0.091 -0.095 -0.102 -0.119 -0.142 -0.167 -0.182
    0 -0.027 -0.022 -0.025 -0.037 -0.05 -0.071 -0.095 -0.12 -0.141
    0 0.057 0.053 0.041 0.021 0.001 -0.026 -0.056 -0.086 -0.104
    0 0.134 0.118 0.094 0.065 0.035 0.002 -0.032 -0.069 -0.097
    0 0.178 0.149 0.113 0.073 0.035 -0.007 -0.056 -0.1 -0.132
    0 0.18 0.14 0.095 0.045 -0.005 -0.059 -0.113 -0.165 -0.211
    0 0.158 0.104 0.046 -0.02 -0.079 -0.148 -0.218 -0.281 -0.333
    0 0.128 0.06 -0.007 -0.085 -0.164 -0.249 -0.329 -0.408 -0.478
    0 0.094 0.013 -0.072 -0.167 -0.259 -0.362 -0.469 -0.569 -0.653


  • administrators

    Looks like the firmware thinks that X10 is not reachable by the probe, hence the initial column of zeros. In the config.g file you posted earlier, the X movement limit (M208 S1 X) is -22 and the probe offset (G31 X) is +32, which puts X10 right on the boundary between reachable and not reachable. Try X11:200 in your M558 command instead of X10:200.



  • That seems to work for the left side of the bed. Still does not seem right yet. This is what I just ran M557 X11:200 Y10:200 S40 and this is what I see only points on right hand row.

    this is the file RepRapFirmware height map file v1 generated at 2017-04-19 12:41 mean error -0.08 deviation 0.13
    xmin xmax ymin ymax radius spacing xnum ynum
    11 200 10 200 -1 40 5 5
    0 -0.176 -0.151 -0.162 -0.202
    0 -0.021 -0.038 -0.076 -0.12
    0 0.115 0.067 0.002 -0.073
    0 0.14 0.041 -0.062 -0.167
    0 0.059 -0.09 -0.255 -0.412

    It did probe X11

    What about the config.json mismatch?


  • administrators

    I just spotted this in your earlier post:

    It also thinks the firmware is 1.17 and I have 1.18.1

    If it thinks the firmware is 1.17, chances are that it is. Send command M115 to check. If the upgrade to 1.18.1 failed, you may need to upload the latest iap4e.bin before you upload firmware 1.18.1.



  • 4:04:02 PM M115
    FIRMWARE_NAME: RepRapFirmware for Duet WiFi FIRMWARE_VERSION: 1.18.1 ELECTRONICS: Duet WiFi 1.0 FIRMWARE_DATE: 2017-04-09

    But the config.json says 1.17

    {"board":"duetwifi10","firmware":1.17,"compatibility":2,"nvram":false,"geometry":{"type":"cartesian","mins":[0,0,0],"maxes":[200,200,180]},"drives":[{"direction":0,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":320,"instant_dv":15,"max_speed":6000,"acceleration":500,"current":800,"driver":0,"endstop_type":1,"endstop_location":1},{"direction":0,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":320,"instant_dv":15,"max_speed":6000,"acceleration":20,"current":800,"driver":1,"endstop_type":1,"endstop_location":1},{"direction":1,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":10240,"instant_dv":0.2,"max_speed":150,"acceleration":250,"current":800,"driver":2,"endstop_type":3,"endstop_location":1},{"direction":1,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":420,"instant_dv":2,"max_speed":20,"acceleration":250,"current":800,"driver":3}],"idle":{"used":true,"factor":30,"timeout":30},"homing_speed_fast":"30","homing_speed_slow":"6","travel_speed":100,"z_dive_height":5,"slow_homing":false,"probe":{"type":"unmodulated","trigger_height":2.5,"trigger_value":443,"x_offset":0,"y_offset":0,"speed":2,"deploy":false,"points":[{"x":30,"y":15,"z":0},{"x":30,"y":180,"z":0},{"x":180,"y":180,"z":0},{"x":180,"y":15,"z":0},{"x":100,"y":100,"z":0}]},"num_nozzles":1,"bed_is_nozzle":false,"bed":{"present":true,"heater":0,"use_pid":false,"width":200,"length":200},"chamber":{"present":false},"max_heater_temperature":260,"heaters":[{"scale_factor":100,"series":4700,"thermistor":100000,"beta":4138,"a":0.0005717725,"b":0.0002416626,"c":0,"channel":0},{"scale_factor":100,"series":4700,"thermistor":100000,"beta":4138,"a":0.0005717725,"b":0.0002416626,"c":0,"channel":1}],"toolchange_wait_for_temperatures":true,"generate_t_code":false,"tools":[{"number":0,"extruders":[0],"heaters":[1],"x_offset":0,"y_offset":0,"z_offset":0}],"compensation_x_offset":15,"compensation_y_offset":15,"mesh":{"x_min":30,"x_max":185,"y_min":15,"y_max":185,"spacing":20},"home_first":false,"orthogonal":{"compensation":false},"network":{"enabled":true,"name":"","password":"","dhcp":true},"fans":[{"value":"30","inverted":false,"frequency":500,"thermostatic":false},{"value":"100","inverted":false,"frequency":500,"thermostatic":true,"heaters":[0,1],"trigger_temperature":45},{"value":"100","inverted":false,"frequency":500,"thermostatic":true,"heaters":[1],"trigger_temperature":45}],"custom_settings":""}



  • Also did you see the heightmap pic? Just one row of data show up. Does not appear to be work as it carved out my PEI !


  • administrators

    I guess that may be an artifact of how DWC responds to the column of zeros. I'll ask chrishamm to check it out.



  • Why am I getting zeros if it is probing X11? What about the rest of the data as well?


  • administrators

    Your config.json file doesn't agreed with the config.g file you posted earlier. Please post your current config.g file again.

    The version number in config.json suggests to me that you created it before you upgraded the firmware.



  • Like I said they don't jive. I did the full firmware again and same thing. Ran m997 no change to config.json

    {"board":"duetwifi10","firmware":1.17,"compatibility":2,"nvram":false,"geometry":{"type":"cartesian","mins":[0,0,0],"maxes":[200,200,180]},"drives":[{"direction":0,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":320,"instant_dv":15,"max_speed":6000,"acceleration":500,"current":800,"driver":0,"endstop_type":1,"endstop_location":1},{"direction":0,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":320,"instant_dv":15,"max_speed":6000,"acceleration":20,"current":800,"driver":1,"endstop_type":1,"endstop_location":1},{"direction":1,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":10240,"instant_dv":0.2,"max_speed":150,"acceleration":250,"current":800,"driver":2,"endstop_type":3,"endstop_location":1},{"direction":1,"microstepping":32,"microstepping_interpolation":true,"steps_per_mm":420,"instant_dv":2,"max_speed":20,"acceleration":250,"current":800,"driver":3}],"idle":{"used":true,"factor":30,"timeout":30},"homing_speed_fast":"30","homing_speed_slow":"6","travel_speed":100,"z_dive_height":5,"slow_homing":false,"probe":{"type":"unmodulated","trigger_height":2.5,"trigger_value":443,"x_offset":0,"y_offset":0,"speed":2,"deploy":false,"points":[{"x":30,"y":15,"z":0},{"x":30,"y":180,"z":0},{"x":180,"y":180,"z":0},{"x":180,"y":15,"z":0},{"x":100,"y":100,"z":0}]},"num_nozzles":1,"bed_is_nozzle":false,"bed":{"present":true,"heater":0,"use_pid":false,"width":200,"length":200},"chamber":{"present":false},"max_heater_temperature":260,"heaters":[{"scale_factor":100,"series":4700,"thermistor":100000,"beta":4138,"a":0.0005717725,"b":0.0002416626,"c":0,"channel":0},{"scale_factor":100,"series":4700,"thermistor":100000,"beta":4138,"a":0.0005717725,"b":0.0002416626,"c":0,"channel":1}],"toolchange_wait_for_temperatures":true,"generate_t_code":false,"tools":[{"number":0,"extruders":[0],"heaters":[1],"x_offset":0,"y_offset":0,"z_offset":0}],"compensation_x_offset":15,"compensation_y_offset":15,"mesh":{"x_min":30,"x_max":185,"y_min":15,"y_max":185,"spacing":20},"home_first":false,"orthogonal":{"compensation":false},"network":{"enabled":true,"name":"","password":"","dhcp":true},"fans":[{"value":"30","inverted":false,"frequency":500,"thermostatic":false},{"value":"100","inverted":false,"frequency":500,"thermostatic":true,"heaters":[0,1],"trigger_temperature":45},{"value":"100","inverted":false,"frequency":500,"thermostatic":true,"heaters":[1],"trigger_temperature":45}],"custom_settings":""}



  • So i was having the same issue of 0's in the first column, and only displaying part of the mesh in the mesh visualizer, I had unwittingly made my X start point value for the probe grid below my X offset and the first column was 0'd out for the 16 point grid.



  • I was 2mm inside the the offset and just for giggles changed it 27mm and shazaam! It started working! I guess you can't be close to the edge…..



  • Now to try a test print.



  • Check my Wonky first layer post; https://www.duet3d.com/forum/thread.php?id=1647


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.