Printing in the Air



  • Dear all, I have a creality ender 5 pro. following Youtube tutorials I manage to slowly but firmly upgrade to Bl Touch, Hemera extruder in Marlin 1.9....and now Duet 2 Wifi with Panel Due5i

    Upgrade firmwares to 2.1.8 , wired all.
    I can see the board and home and move the head around. I can home and even Map the bed or run auto compensations.
    The issue comes on printing. I am using Simplify3d as slicer. The printer ramps temperatures up nicely, but when it supposed to start printing...the head move constantly above the bed (5mm) without touching it and extruding material in the air.

    Here is my config.g file for your consideration.

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Apr 14 2020 22:06:01 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Daniel Ender's 5 Pro" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M569 P4 S1 ; physical drive 4 goes forwards
    M584 X0 Y1 Z2 E3:4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z792.00 E409.00:420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z24.00 E300.00:120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z6000.00 E3600.00:1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E5000.00:250.00 ; set accelerations (mm/s^2)
    M906 X950 Y950 Z950 E950:800 I50 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X220 Y220 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; set active low and disabled endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M558 P9 H5 F300 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-43 Y3 Z-2.337 ; set Z probe trigger value, offset and trigger height
    M557 X0:160 Y0:200 S20 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S300 ; set temperature limit for heater 1 to 300C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss

    Thanks for your help



  • Upgraded to Firmware 3.0 and boy made it worst.

    The bed does not home in either X or Y (I am not sure about the endstops type I have- they are the std Ender 5 pro only closed when home at 0,0)
    The fun thing is they were homing fine in version 2.03
    BL Touch works
    Temp works

    Here is the config file

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Thu Apr 16 2020 21:51:48 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Daniel's Ender 5 pros" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z792.00 E409.00 ; set steps per mm
    M566 X1200.00 Y1200.00 Z12.00 E300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z180.00 E6000.00 ; set maximum speeds (mm/min)
    M201 X800.00 Y800.00 Z100.00 E250.00 ; set accelerations (mm/s^2)
    M906 X950 Y950 Z950 E950 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X220 Y220 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X1 S0 P"xstop" ; configure active-low endstop for low end on X via pin xstop
    M574 Y1 S0 P"ystop" ; configure active-low endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M950 S0 C"exp.heater3" ; create servo pin 0 for BLTouch
    M558 P9 C"zprobe.in+zprobe.mod" H5 F120 T12000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X0:160 Y0:200 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S300 ; set temperature limit for heater 1 to 300C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss


  • Moderator

    @Daniel said in Printing in the Air:

    M92 X80.00 Y80.00 Z792.00

    Hi Daniel. Your original problem sounds like the steps per mm for the Z axis is set too high. And 792 seems like an odd number to use. From a quick googling it looks like 400 should be the correct value and that would be a very common value.

    AS for your RRF3 upgrade woes, I think it would be a good idea to try and go back to 2.05.1 firmware for the time being. Since you have your original config.g in your first post, you can use that. Going back to the old firmware is the same process as updating. Just upload the 2.05.1 bin file from the web interface.

    Let us know how you get along.



  • Thanks Phaedrux, I will give it a try and return.



  • @Phaedrux
    Phaedrux, I took the time to post pictures, old marlin scripts and a whole new config with detail into a new post to include the pages of the configurator with values
    If you help me to go through this I am sure we can conquer this.
    Would you review this for me? The post is named Ender 5 Pro Hemera Bltouch upgrade to Duet Wifi Firmware 3 under Tuning and Tweaking.
    Thanks a lot for your patience. I am trying to fix it at the same time that building a guide for the one coming after.


Log in to reply