Maestro, RRF3, BLTouch Alarm triggered after Homing



  • Hi all,

    I updated to RRF3 yesterday and spent a good part of the day reading up on BLT issues and solutions in the forum. With that, I've made the corrections to my config.g file necessary to home, deploy and retract the BLT; all works great for that. But, my issue is when commanding Home All the probe comes in contact with the bed continuing past 20% duty, probe then retracts while Z continues down slowly, BLT deploys once again and the Z continues down into 80% setting off the alarm and the Z stops about 2mm from E0 hitting the bed, by now the probe is fully retracted and Z goes up 5mm.

    I clear the arlarm with - M280 P0 S160 with a macro command.

    Snippet of config of where changes where made:
    ; Endstops
    M574 X1 S1 P"!^xstop" ; configure active-low endstop for low end on X via pin xstop
    M574 Y1 S1 P"!^ystop" ; configure active-low endstop for low end on Y via pin ystop
    M574 Z1 S2 ; Set endstops controlled by probe **I've tried without too this line.

    ; Z-Probe
    M950 S0 C"zprobe.mod" ; servo/gpio 0 is Z probe MOD pin
    M558 P9 C"zprobe.in" H5 F120 T3000 ; BLTouch connected to Z probe IN pin, free up MOD pin
    G31 P25 X-34 Y18 Z2.497 ; Set Z probe trigger value, offset and trigger height **Tried without this line too.
    M557 X60:220 Y60:220 S20 ; define mesh grid

    **I've commented out the lines out and tried, but same results. I don't know what else to change to get the BLT working as I had it functioned well in RRF 2.05.

    Thanks in advance.👍



  • @Silrocco Your M950 and M558 are round the wrong way. Same problem I had, sure the documentation is wrong....

    This is my working BLT for Maestro

    ; Z-Probe
    M558 P9 C"zprobe.in" H5 F120 T60000 A10 R0.75 S0.02                 ; set Z probe type to bltouch and the dive height + speeds
    M950 S0 C"^zprobe.mod"                             ; create servo pin 0 for BLTouch
    

    HTH

    Paul.



  • @PaulHew said in Maestro, RRF3, BLTouch Alarm triggered after Homing:

    M558 P9 C"zprobe.in" H5 F120 T60000 A10 R0.75 S0.02 ; set Z probe type to bltouch and the dive height + speeds M950 S0 C"^zprobe.mod" ; create servo pin 0 for BLTouch

    Hi PualHew,

    First off, thank you for your reply.

    I made the change you suggested, still getting the same result with this new error:

    G28
    Error: Z probe already triggered at start of probing move



  • @Silrocco
    Please post your homez.g and bed.g.

    This is from my config.g.

    ; Endstops
    M574 X1 S1 P"xstop"                                ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop"                                ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S2                                         ; configure Z-probe endstop for low end on Z
    
    
    ; Z-Probe
    M558 P9 C"zprobe.in" H5 F120 T60000 A10 R0.75 S0.02                 ; set Z probe type to bltouch and the dive height + speeds
    M950 S0 C"^zprobe.mod"                             ; create servo pin 0 for BLTouch
    G31 P500 X42 Y-1 Z1.546
    M557 X42:220 Y20:220 S20
    

    Can you home X and Y independently?

    Regards,
    Paul



  • @PaulHew

    I managed to fix the issue! Yay!!

    Went to the G-Code wiki and made the change by adding the pull up resistor to "C"^zprobe.in"".

    "The pullup resistor on the Z probe input is disabled by default. Enable it by prefixing the input pin (C parameter) with the ^ character. Enable pullup resistor with ^ if using Duet 2, running RRF3, using the Z probe input pin, and the probe type is a switch or BLTouch."
    -Source: https://duet3d.dozuki.com/Wiki/Gcode

    This is my change:
    ; Z-Probe
    M558 P9 C"^zprobe.in" H5 F120 T3000 ; BLTouch connected to Z probe IN pin, free up MOD pin
    M950 S0 C"zprobe.mod" ; servo/gpio 0 is Z probe MOD pin
    M280 P0 S10 ; send control signal to BLTouch through servo/gpio 0

    I appreciate your help! Thank you.


Log in to reply