Lulzbot/E3D Toolhead heatsink fan speed problems



  • So I recently tore the rambo out of my TAZ 5 and I've replaced it with the Duet2 WIFI. Overall this has been pretty great (the noise reduction is sublime) but taken some finagling to get right. The problem I haven't been able to figure out is how to properly control the heatsink cooling fans on the hotend. I have them all connected correctly but I can't seem to accurately control the speed. When I take the fans on the lulzbot aerostruder or on the HS 0.8 toolhead (essentially titan aero extruders) and set them to 100% they blow like freaking crazy. Like these fans sound like they are coming from the back of a fighter jet. There's turbulence all around the extrusion zone and I can hear it from the next room over. When I turn the fans to 99% they hardly blow enough to even move. I can feel the heat creep up the extruder and I'm just waiting for the extruders to jam super bad. If I go any lower than about 90% the fans won't even move. Is this a settings problem or is this just how these fans work? The only 2 controls I see is speed and frequency, I have the speed at 99 or 100 percent and the frequency @ 500Hz.



  • Some fans don't respond well to PWM. See the thread here https://forum.duet3d.com/topic/13936/how-to-limit-the-speed-of-the-hot-end-heatsink-fan?_=1587447391085

    I connected 3 diodes in series with the fan to reduce the voltage from 12v to 10v.

    No problem though with my material cooling turbo fan, it response well to PWM.



  • @redalenca Also check that the vfan jumpers are set to match the voltage required for the fans.


  • administrators

    Try lower PWM frequencies. You may need to go as low as 80Hz. If that doesn't work, you can reduce the fan voltage as @zapta suggested. And yes, check that you are supplying the correct voltage to the fan.


Log in to reply