Extruder motor chokes - speed limitation(?)



  • hi,
    i was calibrating values for my extruder motor when the motor starts to "choke" at certain speed.
    i tried change the value all over but nothing release it from this speed limit.
    im sure with most of my calibration data, 'step per mm' is probably not accurate but still im swinging between stall guard when the 'step per mm' is high and this choke(disturbing noise) when the 'step per mm' is lower.
    i tried to add stall detection commands, i tried to work the extruder motor with no load(tourqe) on it but both actions with no help.
    after the choking the motor is stuck like this until emergency stop is happened and not able to move.
    im sure my motor can move faster his datasheet support it.
    is anybody happened the same? what the meaning of this noise? how is jerk sounds like?

    im using Duet 3 Mainboard 6HC
    and Duet 3 Expansion 3HC
    on web control
    happy for any help thank you before head


  • administrators

    Please post your config.g file.

    What main board and expansion board firmware versions are you using?



  • ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S0 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M569 P4 S0 ; physical drive 4 goes forwards
    M569 P5 S0 ; physical drive 5 goes forwards
    M569 P1.0 S1 ; Drive E0 FEEDER
    M569 P1.1 S1 ; E1 printhead
    ;M569 P1.2 S1 ; Drive E2 FEEDER
    ;M569 P2.0 S1 ; E3 printhead

    M584 X0 U1 Y2:3 Z4:5 E1.0:1.1 ; Use E1 for Z axis
    M350 X16 U16 Y16 Z16:16 I1 ; Configure microstepping with interpolation
    M350 E16:16 I0 ;microstepping without interpolation
    M92 X100 U100 Y80.00 Z462.5 E115:600 ; set steps per mm
    M566 X12000 U12000 Y16000 Z1500 E12000:10000 ; set maximum instantaneous speed changes (mm/min)
    M203 X15000 U15000 Y20000 Z2000 E15000:12000 ; set maximum speeds (mm/min)
    M201 X4000 U4000 Y5000 Z1000 E4000:4000 ; set accelerations (mm/s^2)
    M204 P800 T1000 ; set max accelaration
    M906 X2000 U2000 Y1800 Z2100 E2500:2100 I20 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    M222 12000;

    ; Endstops
    M574 X1 S1 P"io0.in" ; X min active high endstop switch
    M574 Y1 S1 P"io1.in" ; Y min active high endstop switch
    M574 U1 S1 P"io2.in" ; U min active high endstop switch


  • administrators

    And the firmware versions?


  • Moderator

    Can you try and perform this extruder calibration?

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+4:+Calibration/40#s165

    It will also help you find the max volumetric flow rate of your hotend. Skipping can be a result of trying to push through more filament than you can reliably melt.

    What is your extruder? If you initial steps per mm is far off it may take a few attempts to get it correct.



  • @dc42
    RC8 the latest, soon i will do the new RC9



  • @Phaedrux
    thank you i will try it today



  • im adding video-link of this phenomena, does anyone had encountered with this?

    https://youtu.be/ZQNoikOtOLQ

    is it whats called "jerk"? what parameters in config file control this?
    any help will do
    thank you :}
    @dc42


  • administrators

    It looks to me that you have a highly geared extruder and consequently a high steps/mm value. The likely explanation for what you observe is that you do not have sufficient VIN voltage to drive the extruder as fast as you are trying to.

    You can calculate the maximum available speed before serious loss of torque using the EMF calculator at https://www.reprapfirmware.org/.

    If this is the problem, then possible remedies include:

    • Reduce the maximum extruder speed. If you are only trying to use high speeds for filament loading/unloading and retraction, this should be workable.
    • Use a higher VIN voltage, for example if you are using 12V then upgrade to 24V
    • Change to a stepper motor with lower inductance


  • thank you for the help,
    this fault solved by increasing Vin level + decrease motor current


Log in to reply