Dead magnetic sensor?



  • Board: Duet WiFi 1.0 or 1.01 (duetwifi10)
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.05 (2019-12-13b1)
    Duet WiFi Server Version: 1.23
    Duet Web Control 2.1.5

    Lately I was having a lot of false alarms from my very first batch of magnetic sensor.
    this is the config.g code I was using and worked well till last week

    ;M591 D0 P3 S23.2 C3 R20 E5.0  ; Duet3d sensor for extruder drive 0 is connected to endstop input 3 (E0), 23.5mm/rev, 50%  error detection tolerance, 3mm comparison length
    ;M591 D0  
    

    Now the sensor blink 3 times green and then start to blink red continuously at about 2 times for second.
    Looking at the sensor it seems that it was pushed to near to the magnet and maybe it was damaged by the pressure.
    Could be this the reason for the red led behavior?

    If I give a M591 D0 command I receive

    Duet3D magnetic filament monitor on input 3, enabled, sensitivity 24.80mm/rev, allow 70% to 130%, check every 3.0mm, no data received
    

    If I start a print it stop after few seconds going in pause with a blank pop up with only an ok button
    I could try to change the chip but the model isn't readable anymore , is it something like As5600 ?

    IMG_20200426_003709_1 (Media).jpg


  • Moderator

    @claustro said in Dead magnetic sensor?:

    Now the sensor blink 3 times green and then start to blink red continuously at about 2 times for second.

    So 3 green at power up and then only red afterwards? Is there a pattern to the red?

    Status indication LEDs
    In normal operation the filament monitor will flash the green LED 3 times to indicate the magnet is detected. The green LED will then flash periodically red and green indicating communication to the Duet (the green flashes are position reports, the red ones are status reports). If the magnet is rotating the green LED will flash more frequently (can look like almost solid green)

    If the filament monitor fails to initialise after power up, then instead of flashing the green LED 3 times it will flash the red LED to indicate an error. It will continue to try to initialise and flash the red LED until successful initialisation.

    The number of flashes of the red LED indicates the nature of the error, as follows:

    4 flashes: I2C communications error
    5 flashes: I2C channel is in an incorrect state
    6 flashes: Magnet not detected. Typically this means that the magnet is too far away from the sensor chip.

    https://duet3d.dozuki.com/Wiki/Duet3dFilamentMonitor_RotatingMagnetVersion



  • I confirm 3 green at power up and 2 flash per second red continuously , no pattern.



  • @claustro Not sure if this is related but you have an error in the parameter, should be

    M591 D0 P3 L23.2 C3 R20 E5.0
    

    You have a S where it should be L. Will also need to enter a value for S, see https://duet3d.dozuki.com/Wiki/Gcode#Section_M591_Configure_filament_sensing. Also, the second M591 shouldn't be necessary.



  • Thank you for your answer, I 'll check my config but everything worked smoothly till last week. Also I think the red flashing led appear independently from the firmware configuration.
    I discovered that the sensor is AS5600 so I bought a new chip, I am gonna try tho change it hoping to solve my problem.


Log in to reply