Printer printing with z probe now, but I think config is a little hack

  • After getting some assistance prior (thanks everyone!) I finally got my probe working as a type 4 inductive probe (type 5 didn't work with G30 for some reason, but did work with Z homing). It doesn't do bed compensation - the heights are definitely off. But it seems to print on the bed perfectly well right now.

    Because I think this thing is a hacky setup I wanted to know if there was a better way to set this up.

    Full configs are shown here:

    I setup the probe with this:

    M558 P4 I1 Z1 H4 R2 F180
    G31 T4 P100 X-51 Y30 Z1.65
    M557 X10:170 Y10:110 S20

    Noting that I don't actually use the M557 because I am just using homing on Z.

    When it homes, it does:

    G1 Z-200 S1 ; move up to 240mm in the -Z direction, stopping if the homing switch is triggered
    G1 Z4 F600 ; move slowly 4mm in the +Z direction
    G1 Z-10 S1 ; move slowly 10mm in the -Z direction, stopping at the homing switch


    ;G30 ; lower head, stop when probe triggered and set Z to trigger height

    G92 Z1.84

    (Should that use G30?)

    In simplify3d, I tell it the bed is -0.18 relative to 0. (Global GCode offset, on gcode tab).

    When S3d starts the print I have it do:

    G28 ; home all axes
    G29 S2 ;; clear any compensation

    G1 E-5 F180

    G1 Z30 F4800
    G1 X0 Y0 F4800

    G1 E20 F180

    I would rather not have to tell s3d that my bed is lower than 0.

    But with all these settings, it all appears to work pretty well. I would just like to have the most sane setup I can.

    Any help is appreciated.

  • Wow you got S3D to work! I still can't. But then I still have issues just getting Repetier to work.

  • administrators

    You are using a microswitch for Z homing. If you increase the Z parameter in your G92 command by 0.18mm, this should get rid of the bed height offset.

    You can use the Z probe to do Z homing if you prefer, by using G30 instead of G1 S1/G92. See

Log in to reply