Issues after installing IR Probe Z Printing in the air?



  • Hi guys,

    Hoping someone can help me here, I have been at this all day and now I am starting to go crazy...

    After disabling soft end-stops, setting Z=0 and running G30 S-1 I got a very good average of 1.63 which I added to my config.g:

    ; Z-Probe
    M558 P1 H5 F300 T6000 A5 S0.015 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X-45 Y-10 Z1.63 ; set Z probe trigger value, offset and trigger height

    After running the bed compensation, all looked well. (I just started with 4 points to test, image attached)
    Capture.JPG

    However now I put a print on and the Z starts at 1.75

    It has me baffled!

    It also appears that when I use the baby-stepping to get the nozzle on the bed, the Z-Axis auto-corrects when it changes a corner.

    It does not appear to be S3D as my GCode preview shows printing from Z=0.25 for the correct layer height.

    HELP!

    Config.g below

    0:/sys/config.g
    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Apr 28 2020 16:27:26 GMT+1000 (Australian Eastern Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"HTHE" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P4 S0 ; physical drive 4 goes backwards
    M584 X0 Y1 Z2 E4 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X88.89 Y88.89 Z400.00 E578.00 ; set steps per mm
    M566 X900.00 Y900.00 Z30.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z600.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z400 E1000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X230 Y140 Z150 S0 ; set axis maxima

    ; Endstops
    M574 X2 Y2 S0 ; set active low and disabled endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M558 P1 H5 F300 T6000 A5 S0.015 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X-45 Y-10 Z1.63 ; set Z probe trigger value, offset and trigger height
    M557 X0:185 Y0:130 S40 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S180 ; set temperature limit for heater 0 to 180C
    M305 P1 X200 ; configure PT100 for heater 1
    M143 H1 S420 ; set temperature limit for heater 1 to 420C

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 S"HTHE Extruder" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings
    M305 P1 X200 ; Enable PT100 DB Intergration

    ; Miscellaneous

    HTHE
    Send code...
    Status
    Idle
    Tool Position
    X
    0.0
    Y
    0.0
    Z
    0.00
    Extruder Drives
    Drive 0
    0.0
    Speeds
    Requested Speed
    0 mm/s
    Top Speed
    0 mm/s
    Sensors
    Vin
    23.9 V
    MCU Temperature
    35.4 C
    Fan RPM
    0
    Z-Probe
    0
    Tools
    Extra
    Control All
    Tool Heater Current Active Standby
    HTHE Extruder
    T0 - Load Filament Heater 1
    off 68.1 C
    0
    0
    Bed Heater 0
    off 43.5 C
    0
    Temperature Chart
    System Directory


  • Moderator

    What do you have in your homeall?
    What do you have in your slicer start gcode?

    To allow the baby stepping to go down below what it thinks is Z0 you would need to modify your M208 minima to allow a slightly negative value like -1mm. But hopefully we can figure out why your prints are starting so high and that won't be necessary.



  • Thanks for your help!

    So my home all shows as:

    G91 ; relative positioning
    G1 H2 Z5 F2400 ; lift Z relative to current position
    G1 H1 X235 Y145 F2400 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X-5 Y-5 F2400 ; go back a few mm
    G1 H1 X235 Y145 F300 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X100 Y40 F2400 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    and my start script is:

    M561 ; Clear any bed transform
    G28 ; Home machine
    G32 ; Run bed compensation
    G29 S1 ; Enable mesh compensation

    Is there something obvious I am not skilled enough to see?



  • @Phaedrux said in Issues after installing IR Probe Z Printing in the air?:

    What do you have in your homeall?
    What do you have in your slicer start gcode?

    To allow the baby stepping to go down below what it thinks is Z0 you would need to modify your M208 minima to allow a slightly negative value like -1mm. But hopefully we can figure out why your prints are starting so high and that won't be necessary.

    Thanks for your help!

    So my home all shows as:

    G91 ; relative positioning
    G1 H2 Z5 F2400 ; lift Z relative to current position
    G1 H1 X235 Y145 F2400 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X-5 Y-5 F2400 ; go back a few mm
    G1 H1 X235 Y145 F300 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X100 Y40 F2400 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    and my start script is:

    M561 ; Clear any bed transform
    G28 ; Home machine
    G32 ; Run bed compensation
    G29 S1 ; Enable mesh compensation

    Is there something obvious I am not skilled enough to see?


  • Moderator

    what do you have in bed.g?



  • @Phaedrux said in Issues after installing IR Probe Z Printing in the air?:

    what do you have in bed.g?

    M561 ; clear any bed transform
    G29 ; probe the bed and enable compensation


  • Moderator

    And your heightmap only has 4 points? Or are you using more now?

    Expanding your gcode for the start of the print we get

    M561 ; Clear any bed transform
    G91 ; relative positioning
    G1 H2 Z5 F2400 ; lift Z relative to current position
    G1 H1 X235 Y145 F2400 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X-5 Y-5 F2400 ; go back a few mm
    G1 H1 X235 Y145 F300 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X100 Y40 F2400 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed
    M561 ; clear any bed transform
    G29 ; probe the bed and enable compensation
    G29 S1 ; Enable mesh compensation

    I don't think there's anything wrong in there.



  • @Phaedrux said in Issues after installing IR Probe Z Printing in the air?:

    And your heightmap only has 4 points? Or are you using more now?

    Expanding your gcode for the start of the print we get

    M561 ; Clear any bed transform
    G91 ; relative positioning
    G1 H2 Z5 F2400 ; lift Z relative to current position
    G1 H1 X235 Y145 F2400 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X-5 Y-5 F2400 ; go back a few mm
    G1 H1 X235 Y145 F300 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X100 Y40 F2400 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed
    M561 ; clear any bed transform
    G29 ; probe the bed and enable compensation
    G29 S1 ; Enable mesh compensation

    I don't think there's anything wrong in there.

    Thanks for you time reading.

    The problem has been solved but rather frustratingly, I still don't know why.

    I ended up opting for the nuclear solution and erasing the SD, installing a known config and changing everything I thought I had changed previously one-by-one.

    So in short, I have no idea what was causing the in-air print at layer one... the G Code I was using previously is the same one so I am confident it was an error in my Duet code somewhere...

    This will be chewing at my brain forever haha


Log in to reply