Attaching PanelDue 4.3



  • I have my DuetWifi and panelDue tried to connect but all i get is "connecting"? It never connects, I have made sure that my baud rate is set in both places correctly. What am i missing? I ordered both together thought it would have been tested to ensure it worked before it was sent out.


  • administrators

    Both baud rates default to 57600 so you should not need to change them. The usual cause of connection failure is a faulty cable. The colours of the wires should be in the exact opposite order at the two ends of the cable.



  • @dc42:

    Both baud rates default to 57600 so you should not need to change them. The usual cause of connection failure is a faulty cable. The colours of the wires should be in the exact opposite order at the two ends of the cable.

    The screen comes up but in the at the top is a red bar that just says connecting. i have checked wires and they appear to be correct.


  • administrators

    It does sound like a hardware fault then. But it could be the PanelDue, the cable, or the Duet. Unless you have another Duet or PanelDue that you can test with, I guess the simplest is to send you a new PanelDue controller and cable in the first instance. Tony, can you arrange this?



  • I just have what I ordered in Batch 2. I have recently ordered another DuetWifi Batch 5 to upgrade another printer. Anything you can do would be greatly appreciated,


  • administrators

    Yes we will contact you to arrange a swap of controller and cable.


Log in to reply