Nozzle fan not blowing above 50%



  • I'm using Simplify 3d and have my nozzle fan set to 75%. In DWC they are off by default and I have to turn them on and pin them. They should be triggered by the g-Code correct? They have been fine in the past, however now you need to turn them on and you CANNOT go above 50% or they shut off? Thoughts? This was never an issue before. Thank you

    Duet 3d Maestro FW: 2.05 (2019-12-13b1)


  • Moderator

    Please post your config.g so we can see how the fans are configured and a sample of gcode from simplify that shows how it's trying to turn on the fan.



  • ; CONFIGURATION FILE for Duet Maestro
    ; K'Tana Nozzle
    ; Last modified October 1, 2018

    ; Executed by the firmware on start-up

    ; Headers within parenthesis are headings in Duet3D documentation=https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer
    ; Visit https://reprap.org/wiki/G-code for an explanation of G-code commands

    ; --- SECTION: GENERAL PREFERENCES ( ) ---

    M564 S1 H1 ; Enables Homing Requirement For Motor Activation and set axes limits

    ; --- SECTION: Z-PROBE & MESH COMPENSATION ---

    M98 Pmachine_zprobe.g ; configure the z probe

    M98 Pmachine_bedmesh.g ; configure the bed mesh

    G29 S1 ; Load heightmap after power cycle

    ; --- SECTION: DRIVES (MOVEMENT SECTION) & ENDSTOPS ---

    M667 S1 ; Enable coreXY mode
    M569 P0 S0 ; Drive 0 goes forwards, CoreXY_1
    M569 P1 S1 ; Drive 1 goes forwards, CoreXY_2
    M569 P2 S1 ; Drive 2 goes forwards, Z Motor
    M569 P3 S0 ; Drive 3 goes forwards, Left Extruder
    M569 P4 S1 ; Drive 4 goes forwards, Right Extruder
    M98 Pmachine_endstoptypes.g ; set endstop types
    M98 Pmachine_steppercurrent.g ; set stepper currents
    M98 Pmachine_stepperspeed.g ; set stepper speeds
    M98 Pmachine_axisdimension.g ; configure the axes dimensions
    M98 Pmachine_axissteps.g ; configure the axes steps per mm
    M98 Pmachine_extruderstep.g ; configure the extruder steps
    G21 ; Work in millimetres
    G90 ; Set to absolute coordinates...
    M84 S1 ; Set idle timeout

    ; --- SECTION: HEATERS, BED & THERMISTOR ---
    ; H0 is bed
    ; H1 is left heater
    ; H2 is right heater

    M570 H0 P25 T30 ; Allow heater to be off by as much as 30C for 25 seconds
    M570 H1 P15 T30 ; Allow heater to be off by as much as 30C for 15 seconds
    M570 H2 P15 T30 ; Allow heater to be off by as much as 30C for 15 seconds
    M305 P0 T100000 B4138 C0 R2200 ; Set thermistor + ADC parameters for heater 0, For heated Bed thermistor
    M305 P1 X501 R2200 ; Define left side extruder PT1000
    M305 P2 X502 R2200 ; Define right side extruder PT1000
    M307 H0 A78.9 C265.2 D9.5 S1.00 V24.0 B0 ; Forcing heated bed PID control after power-cycle. Basic bed heating auto-tune
    M307 H1 A309 C96 D5.2 S0.75 V24.1 B0 ; Set PID values use M303 auto-tune calibration settings
    M307 H2 A309 C96 D5.2 S0.75 V24.1 B0 ; Set PID values use M303 auto-tune calibration settings
    M302 P1 ; Allow Cold extrudes
    M98 Pmachine_maxtemp.g ; set bed and extruder max temperatures

    ; --- SECTION: FANS ( ) ---

    M106 P0 S0 I0 F4 H-1 L0.3 ; Filter fan. Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%
    M106 P1 S0 I0 F4 H-1 L0.3 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%
    M106 P2 S0 I0 F4 H-1 L0.3 ; Nozzle fan. Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%

    ; --- SECTION: TOOLS ( ) ---

    ; Comment: Remember! H0 is the heated bed!
    ; Comment: D0 is the first driver after movement (X, Y and Z) drives, which is left extruder
    ; D1 is right extruder

    M98 Pmachine_ktana_tools.g ; Define ktana tools

    T0 ; Automatic tool select

    ; --- SECTION: NETWORKS (PROLOGUE & COMMUNCATIONS SECTION) ---
    M98 Pmachine_access.g ; set machine name and IP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; --- SECTION: MISCELLANEOUS ---

    M572 D0:1 S0.07 ; Extruder Pressure Advance


  • Moderator

    @Stephenbright said in Nozzle fan not blowing above 50%:

    M106 P0 S0 I0 F4 H-1 L0.3 ; Filter fan. Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%
    M106 P1 S0 I0 F4 H-1 L0.3 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%
    M106 P2 S0 I0 F4 H-1 L0.3 ; Nozzle fan. Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%

    It's likely the F4 that is setting the PWM frequency to 4hz. Default is 500. Test with some different values. Under 10 can be problematic. Each fan is a bit different. Values from 10 to 30000 are valid.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M106_Fan_On



  • Specifically which number do I change on there? M106 P0 S0 I0 F4 H-1 L0.3. Thank you !


  • Moderator

    @Phaedrux said in Nozzle fan not blowing above 50%:

    It's likely the F4

    @Phaedrux said in Nozzle fan not blowing above 50%:

    Default is 500.



  • Ohhh okay... The 4 in the F4 is 4hz. I'll change it to F500 ( 500hz)

    I thought F4 was the actual command...

    Thank you !



  • I changed the F4 to F500 then to F1000 and still nothing... It's only spins slowly if I have them turn on to 50%. I know they were as they are new fans and again spin but just at a slow speed... Any other thoughts?

    Thanks !



  • @Stephenbright said in Nozzle fan not blowing above 50%:

    Duet 3d Maestro FW: 2.05 (2019-12-13b1)

    Update. This printer has duel extrusion capabilities however I removed the original left T0 nozzle. I have the nozzle on the T1 right side port and that fan is the fan that is blowing slow. On the left I removed my original nozzle T0 and that fan is going 100 % blowing a now removed nozzle ( I tried two nozzles and that was a mess so I took the original left one out ) Can you see in the config where I have them mixed up?



  • @Stephenbright said in Nozzle fan not blowing above 50%:

    ; --- SECTION: FANS ( ) ---
    M106 P0 S0 I0 F4 H-1 L0.3 ; Filter fan. Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%
    M106 P1 S0 I0 F4 H-1 L0.3 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%
    M106 P2 S0 I0 F4 H-1 L0.3 ; Nozzle fan. Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%

    I bought it direct from M3d. I can easly just swap the fan to the other side, but was trying to figure out why this happend and how to fix it. Thank you !


  • Moderator

    You can change which fan is assigned to which tool in your tools definition. Your config posted above doesn't include your tools definitions (it's in another macro), so I'm not sure what to change.



  • Question: Is this the latest firmware version for 2.xx

    2.05 (2019-12-13b1)

    I guess our printers don't like version 3.xx just yet. M3D Promega

    Thanks !



  • @Stephenbright said in Nozzle fan not blowing above 50%:

    Is this the latest firmware version for 2.xx
    2.05 (2019-12-13b1)

    https://github.com/Duet3D/RepRapFirmware/releases/tag/2.05.1


Log in to reply