Tuning Maestro Stepper Drivers



  • Hi guys. I am looking for some insight on tuning the stepper drivers on my Maestro, for a couple reasons.

    I haven't found stealthchop very useful, due to the switch to spreadcycle. With default settings, I was operating almost entire in spreadcycle. So, I tried dropping the M569 V parameter until all my normal printing speeds were covered (30 - 60mm/s). Even though it hasn't been shifting layers, it makes a really loud clunk when doing a 180 mm/s positional move and switching to spreadcycle.

    My setup: Ultimaker Original cartesian printer. Running these steppers on X and Y, on a Maestro at 24v on RRF 3.01-RC11:

    2f16df41-0b59-4b40-a021-579077c3e2ce-image.png

    Is there some additional tuning I can do to get these steppers working more seamlessly in stealthchop?

    .
    .
    .

    On my Z axis, the motion is quite loud (for continuous moves). Part of it, is the sound amplification from the printer's bottom panel. But, the motor could definitely run more quietly as well. Getting it into stealthchop has helped a good bit. Is it generally okay to run a Z axis in stealthchop?. Here are the motor spec's:

    71e6f93a-a41b-4e2f-988d-b45418bf9416-image.png

    .
    .
    .

    My drive configuration in RRF3.01-RC11:

    ; Drives
    M569 P0 S1                                             ; physical drive 0 goes forwards
    M569 P1 S0                                             ; physical drive 1 goes backwards
    M569 P2 S0                                             ; physical drive 2 goes backwards
    M569 P3 S0                                             ; physical drive 3 goes backwards
    
    M569 P0 V77					; Stealthchop2 till about 60 mm/sec
    M569 P1 V77 					; Stealthchop2 till about 60 mm/sec
    M569 P2 V60 					; Stealthchop2 till about 30 mm/sec
    M569 P3 D2 					 ; Extruder in Spreadcyle
    
    M584 X0 Y1 Z2 E3                                       ; set drive mapping
    M92 X159.93 Y159.75 Z400.00 E510                       ; set steps per mm
    M350 X16 Y16 Z8 E16 I1                                 ; configure microstepping with interpolation
    M566 X800.00 Y800.00 Z600.00 E200.00                   ; set maximum instantaneous speed changes (mm/min)
    M203 X12000.00 Y12000.00 Z1800.00 E2400.00             ; set maximum speeds (mm/min)
    M201 X4000.00 Y4000.00 Z1200.00 E1500.00               ; set max accelerations (mm/s^2)
    M204 P2500 T4000                                       ; set accelerations (mm/s^2)
    M593 F00                                               ; dynamic accel cancel 50 hz
    
    
    M906 X1300 Y1300 Z1400 E1200 I30                       ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                                ; Set idle timeout
    


  • Anyone?

    Since I can't get the transition from stealthchop to spreadcycle to happen without the loud "clunk", I have started running the motors in spreadcycle all the time now. Unfortunately, now they hiss both at idle and during a print.

    Anything I can do to tune some of this "hiss" out?


  • administrators

    @CCS86 said in Tuning Maestro Stepper Drivers:

    Anyone?

    Since I can't get the transition from stealthchop to spreadcycle to happen without the loud "clunk", I have started running the motors in spreadcycle all the time now. Unfortunately, now they hiss both at idle and during a print.

    Anything I can do to tune some of this "hiss" out?

    The default setting is to use stealthChop at idle and very low speeds, so that the motors are very quiet when at idle.

    To make the motors quieter at idle and low speeds if in spreadCycle mode, use M917 to reduce the standstill current percentage.



  • @dc42 said in Tuning Maestro Stepper Drivers:

    @CCS86 said in Tuning Maestro Stepper Drivers:

    Anyone?

    Since I can't get the transition from stealthchop to spreadcycle to happen without the loud "clunk", I have started running the motors in spreadcycle all the time now. Unfortunately, now they hiss both at idle and during a print.

    Anything I can do to tune some of this "hiss" out?

    The default setting is to use stealthChop at idle and very low speeds, so that the motors are very quiet when at idle.

    To make the motors quieter at idle and low speeds if in spreadCycle mode, use M917 to reduce the standstill current percentage.

    Thank you for the reply. The hissing I hear seems very constant when in motion or at idle. I could go back to the default setting to get quieter idle. But I guess that means I'm stuck with the printing noise.

    Is there any chance that RRF implements that idea of looking at commanded speed of upcoming moves and proactively makes the spreadcycle switch before the motor even begins the acceleration, if that move is commanded above the threshold speed?


Log in to reply