Bltouch V 3.1 Duet2



  • Hello everyone,

    I have a problem with my new bltouch. I have always had a Chinese Bltouch and it has worked "correctly". Yesterday I tried to change that Chinese bltouch for an AntClabs Bltouch.

    My surprise has been that this new Bltouch does not work correctly and when I home and touch the probe (to test its behavior) it starts to flash and stays in "failure" mode

    This is the config.g part:
    ; Z-Probe
    M950 S0 C "exp.heater3"; create servo pin 0 for BLTouch
    M558 P9 C "zprobe.in + zprobe.mod" H8 F250 T6000; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X23 Y9 Z1.5; set Z probe trigger value, offset and trigger height
    M557 X30: 300 Y30: 300 S30;

    This is the homeall
    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sun Mar 29 2020 18:33:49 GMT + 0200 (CEST)
    G91; relative positioning
    ; G1 H2 Z5 F6000; lift Z relative to current position
    G1 H2 Z20 F6000; lift Z relative to current position
    G1 H1 X-305 Y-305 F1800; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000; go back a few mm
    G1 H1 X-305 Y-305 F360; move slowly to X and Y axis endstops once more (second pass)
    G90; absolute positioning
    G1 X55 Y35 F6000; go to first bed probe point and home Z
    G30; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ; G91; relative positioning
    G1 Z5 F100 S2; lift Z relative to current position
    ; G90; absolute positioning

    This is the home z
    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sun Mar 29 2020 18:33:49 GMT + 0200 (CEST)
    G91; relative positioning
    G1 H2 Z5 F6000; lift Z relative to current position
    G90; absolute positioning
    G1 X70 Y35 F6000; go to first probe point
    G30; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    G91; relative positioning
    G1 Z5 F100 S2; lift Z relative to current position
    G90; absolute positioning

    This is the deployprobe.g configuration:

    M280 P0 S10; deploy BLTouch

    This is the configuration of retracprobe.g:
    M280 P0 S90; retract BLTouch

    Surely there is something wrong but I don't know where to look.

    Thanks a lot



  • @chaparro2001 there was a comment by David here: https://forum.duet3d.com/topic/16093/upgrading-from-rrf2-to-rrf3-issues/4
    maybe this helps you.



  • @JoergS5 Yes that's the mistake

    Thanks a lot


  • Moderator


Log in to reply