SD Card Smoked and Burned



  • Hello All

    I was setting up my new Duet 2 WIFI. I had been having issues with my end stops not working so i decided to go with stall detection. Everything seemed to be working fine i removed my end stop wires from the board and continued testing. when suddenly i started smelling smoke. I turned off the machine and found that the SD card was very hot (burned me a little when i ejected it) the SD card has clear heat damaged and looks like it started to burn. Now the board is not responsive. I unplugged everything (except the heated bed and hotend because they dont unplug) and tried to turn the system back on. after a few min i noticed a burning smell, my hot end was on full blast. Im not sure whats wrong any ideas? it will not connect to USB and when i plug in the SD card when it is on usb power it starts smoking again.



  • Sounds like a short to 3.3v.

    Please follow https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond

    and share the status from each step. Take some pictures before disconnecting stuff as well, may come in handy later to try and prevent it from happening again.


  • administrators

    It sounds like your microSD card was excessively bent - in fact I had a similar problem with a damaged microSD card a while back. It became too hot to touch so I had to replace it. Does the board still turn on with the microSD card removed? Before you check that, please verify that there is no visible damage on the board.



  • I already unplugged everything. when i plug in USB all of the lights seem to come on. IMG_20200507_122938.jpg I do not see any burned chips or anything like that IMG_20200507_122915.jpg



  • Maybe try firmware recovery but its a long shot.

    If anything on the board feels hot when running of USB then stop.

    Btw, just lighting or a hole?
    c0fecf1b-e7fa-4ddc-be98-fb88dfcce76d-image.png



  • @bearer said in SD Card Smoked and Burned:

    Maybe try firmware recovery but its a long shot.

    If anything on the board feels hot when running of USB then stop.

    Btw, just lighting or a hole?
    c0fecf1b-e7fa-4ddc-be98-fb88dfcce76d-image.png

    Ah yeah good catch i did not see that! Looks like a hole to me. IMG_20200507_130140.jpg

    I have tried 2 usb cables 2 computers and no dice on connectivity.



  • @skywurz said in SD Card Smoked and Burned:

    I have tried 2 usb cables 2 computers and no dice on connectivity.

    yeah, long shot. with a hole in U10 you woulnd't be able to run motors no matter what happened; odds are you'll need a couple of chips replaced.



  • @bearer said in SD Card Smoked and Burned:

    @skywurz said in SD Card Smoked and Burned:

    I have tried 2 usb cables 2 computers and no dice on connectivity.

    yeah, long shot. with a hole in U10 you woulnd't be able to run motors no matter what happened; odds are you'll need a couple of chips replaced.

    Yeah trying the instructions when i jumper the erase pin i do not get the diag light and then the board starts smelling hot. the large chip becomes hot to the touch.



  • For posterity here is the SD card
    IMG_20200507_135228.jpg
    IMG_20200507_135546.jpg

    And a screen shot of my voltage from the web console

    Duet 2 wifi.JPG



  • Just wanted to post an update. i have re-installed my old controller (Rambo) and swapped back all of my electronics and nothing seems a miss. I want to point out i had not changed any 5v connectors during the swap to or from the duet and i did not install or move any 24v connectors (bed,hotend) while the system was powered on.


  • administrators

    Hi @skywurz, I'm sorry your board has failed. We'll give you the benefit of the doubt and provide a replacement under warranty. Please contact your supplier. If you bought it direct from Duet3D, https://www.duet3d.com/warranty.



  • @dc42 Thank You!!!


Log in to reply