datetime -> RRF



  • If I understand correctly, now when I open web to the RRF it will set the correct datetime on RRF. This works rather ok, but if I'm in DWC, I send M999, board reboots, DWC reconnect but datetime is gone. Or I'm in DWC, I powercycle the printer, DWC reconnect and datetime is gone. Can we have a "button" that "set datetime from browser on RRF" ?


  • administrators

    DWC should always set the datetime when it connects or reconnects. Which version are you using?



  • @dc42 2.1.7
    I look at it like this, if I open DWC and then upload file using curl the file has ok datetime set, if I reboot the RRF, dwc reconnects automatically, upload file using curl, file in most cases has no datetime set



  • @dc42 connected, used a bit, 2:38:31AM - powercycle, it reconnected, datetime is ok, 2:39:25 sent M112, clicked on "reboot", clock after that - not set

    ed50cc48-8b6d-4b8c-9451-3011cefecb98-image.png

    now click on emergency stop button (top right)
    again time not set

    af77d84c-4e88-4ef8-8119-c0b1631bfd32-image.png

    clicking trough DWC, diagnostic .. code still not set ... need to go to initial page ( / ) for clock to be set
    b26ec587-c29a-45de-8175-731a8650dc39-image.png

    now again, emergency stop button...

    and again, clock not set

    94d3671c-c42d-41c4-81fa-188a3fd4fe5a-image.png



  • it looks like "green - connected to" info happens when it sets datetime and orange "attempting to reconnect" does not, probably after the orange one the green one should happen but it does not even as the connection is back


  • administrators

    This is being fixed in the next release of DWC.



  • confirmed - fixed in 3.1.0


  • administrators

    Thanks for confirming.


Log in to reply