Unable to connect



  • Hello,

    I purchased one of the original Duet Wifi V1.02 in mid-2017 (never used) and I finally got around to setting up a new 3d printer this month but the card is now unresponsive. It came up initially and I setup the wifi but then it just died. I've tried fallback methods 1 & 2 (https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware) with no luck. Fallback #3 isn't for my model but I tried pushing the erase button several times and no luck. When I terminal over the serial port on my Mac (at any baud rate), I just get a blank screen and when I try to connect from my Astrobox, it just spins.

    I've been waiting for almost 3 years to use this card so any help would be appreciated.

    Thank you,
    MB



  • @MB said in Unable to connect:

    Fallback #3 isn't for my model

    elaborate? it should work for all Duet boards given you pick the correct binary file to send.

    baud rates doesn't matter over (this type of) usb serial, but it does sound like the board is in the bossa bootloader and using the bossa software to send the Duet2CombinedFirmware.bin file should recover your Duet 2 Wifi v1.02. (although you might have to try from a non-mac computer if it doesn't work)


  • Moderator

    https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond

    Take a look at this and see how far you can get.



  • Thanks guys.

    I managed to get the board to connect and upload the latest firmware - both Duet2CombinedFirmware.bin and DuetWiFiServer.bin.

    Now my only issue is getting the board to accept my camel case SSID & password. I've tried using single quotes before each lower case, creating a macro, and creating a macro with single quotes for lower cases... Any suggestions?

    Cheers!


  • Moderator

    The macro option should work. You don't need to use the single quotes that way.

    Create these macros. Modify them with your ssid and password.

    ; Clear all wifi networks
    ;
    M291 R"Clear WIFI networks? Y/N" P"Caution. New network must be added." S3 T10
    M552 S0			; Disable network module
    G4 S5			; wait 5 second
    M588 S"*"			; Clear all saved wifi network
    M291 R"WIFI networks forgotten." P"You must add a new WIFI network."
    
    ; Add default wifi network
    ;
    M291 R"Add default WIFI network? Y/N" P"This will add duetwifi access point." S3 T10
    M552 S0			; Disable network module
    G4 S5			; wait 5 seconds
    M587 S"ssid" P"password"			; Add duetwifi SSID to remembered networks list
    G4 S5			; wait 5 seconds
    M552 S1			; reenable wifi module
    M291 R"duetwifi SSID added." P"Check console to verify IP address."
    


  • That work! Thank you.

    Does this look in order?

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 3.01-RC12 (2020-05-06b1)
    Web Interface Version: 1.15a


  • Moderator

    @MB said in Unable to connect:

    Web Interface Version: 1.15a

    You'll need to manually update your DWC files.

    https://github.com/dc42/RepRapFirmware/releases/download/3.01-RC12/DuetWebControl-SD-2.1.7.zip

    Unzip that into the /www folder on your SD card.

    Also send M122 and check the wifi server version (near the end of the report). It should be 1.23.



  • All good now. Thanks



  • Hello guys,

    My Duet Wifi is working perfectly but I can't get it to connect with my PanelDue 7 (with v2.0 daughter card). I've confirmed that both the PanelDue and Duet Wifi on channel P1 are both set to 57600 and the everything is running the latest firmware (panel is running 1.24). They are connected using a 4 wire ribbon cable and I tested each lead since I don't have a spare cable. I've looked through all the posts and couldn't find anything more to try. Any suggestions?

    Thanks!



  • @MB said in Unable to connect:

    3.01-RC12

    @MB said in Unable to connect:

    but I can't get it to connect with my PanelDue 7

    you do have M575 P1 S1 B57600 in your config.g?

    reg https://github.com/dc42/RepRapFirmware/blob/v3-dev/WHATS_NEW_RRF3.md#reprapfirmware-301-rc12



  • Ha! That was it. Thanks


Log in to reply