TLM not remembering home ,Smart Effector not reaching bed.



  • So I've converted a TLM Delta to DuetWiFi and smart effector.
    I previously used a Bl-Touch and have re-commissioned it after being idle for 2 years.

    I am also running the latest stable RepRap 3.00

    The problem I'm having is inconsistent homing.
    ie: Sometimes, my Z will home at 500mm (correct).
    Other times it will fail homing, and I will have to home again. (it will report a height like 935mm, ect)

    As well, if I set my home height in config.g to the correct value, my smart effector will not reach the bed.

    The only way I can get a proper calibration is to add 50mm to my homed height. This will allow a full calibration, but of course it's "fake" and once the printer attempts to home, everything is undone.

    I know, just manually adjust "Z"... basic stuff right?
    Except, I can't. Even if I enter in a new z offset, it is gone the moment the printer homes, or you turn it off.

    I have tried, setting new Z with G92, saving with M500, entering the new z offset, ect...
    I've tried with config-override.g, without.

    Basically, my printer just does not "remember" where Z0 is, or where Z500 is.

    I have checked my endstops, all trigger properly.
    The Smart Effector is working as well.

    I should mention I last successfully used this printer under 2.03, with a BL-Touch
    Is there a bug with 3.00 that I'm running into?

    I'm a bit at my wit's end right now, I'm sure I'm missing something obvious
    Any and all help would be appreciated.

    config.g homedelta.g bed.g



  • M665 L250 R160 B80 H240 X0 Y0 Z0

    Change the H value in config and override by the amount you move the nozzle to reach a slip fit with paper, save config, home, check, save config, change rinse repeat until it will home and go to z0 with slip fit. May have to M564 H0 S0 to reach bed.


Log in to reply