Problem when Homing X & Y "Alone"



  • Recently I noticed that when I home X or Y, after it homed, my carriage move more on the X Axis.
    When I home All it works great.
    Also when I finish a print it homes to -2.5mm on the X-Axis.
    I honestly do not know what causes this.
    Here is my HomeX:

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Sat Nov 30 2019 14:18:00 GMT-0500 (heure normale de l’Est nord-américain)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-335 F1800 ; move quickly to X axis endstop and stop there (first pass)
    G1 H2 X5 F6000 ; go back a few mm
    G1 H1 X-335 F360 ; move slowly to X axis endstop once more (second pass)
    G1 H2 Z-5 F6000 ; lower Z again
    G90 ; absolute positioning

    Thanks you


  • Moderator

    Please post your other homing files and your config.g

    What kind of a printer is it?

    What firmware version are you using?

    What Duet board?



  • I own a home built CoreXY with a DuetWifi

    Config
    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Sat Nov 30 2019 14:17:59 GMT-0500 (heure normale de l’Est nord-américain)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    M667 S1 ; select CoreXY mode

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X160.00 Y160.00 Z800.00 E837.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X330 Y270 Z295 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y2 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y40 Z0 ; set Z probe trigger value, offset and trigger height
    M557 X15:315 Y40:265 S20 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    HomeY
    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Sat Nov 30 2019 14:18:00 GMT-0500 (heure normale de l’Est nord-américain)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 Y285 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 H2 Y-5 F6000 ; go back a few mm
    G1 H1 Y285 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 H2 Z-5 F6000 ; lower Z again
    G90 ; absolute positioning

    HomeAll
    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Sat Nov 30 2019 14:17:59 GMT-0500 (heure normale de l’Est nord-américain)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-335 Y285 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 H1 X-335 ; home X axis
    G1 H1 Y285 ; home Y axis
    G1 X5 Y-5 F6000 ; go back a few mm
    G1 H1 X-335 F360 ; move slowly to X axis endstop once more (second pass)
    G1 H1 Y285 ; then move slowly to Y axis endstop
    G90 ; absolute positioning
    G1 H2 X15 Y15 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning


  • Moderator

    @Nylkos said in Problem when Homing X & Y "Alone":

    G1 H2 X15 Y15 F6000 ; go to first bed probe point and home Z

    Do not use H2 in that command in homeall. Remove the H2. You should also position the probe in the center of the bed rather than the corner.

    Also, remove the H2 from the second move to back away from the endstop. It's not needed after the axis is homed once, and on a corexy printer the H2 will move the independent motor, which can cause issues.

    From homex and homey
    G1 H2 Y-5 F6000 ; go back a few mm
    G1 H2 X5 F6000 ; go back a few mm

    Note that homeall doesn't have the H2 on the X and Y moves.

    @Nylkos said in Problem when Homing X & Y "Alone":

    G31 P500 X0 Y40 Z0 ; set Z probe trigger value, offset and trigger height

    You're missing a trigger height in this command. See here: https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe


Log in to reply