Very loud motors



  • Hi guys,

    I'm currently in the phase of building my first 3D printer and unfortunately the movements of the printer are very loud/digital sounding.

    I am using a Duet 3 on RFF 3.1 with 24V power supply. One of the main points of this board for me was the "silent" stepper drivers.
    I am very disappointed right now about the noise and hope it maybe is just a configuration issue?

    This video shows the noise problem I have: https://youtu.be/O4xaL3oMB-Y

    This is the config section for the motors: 98365823_689070671930822_6031387432350384128_o.jpg

    I have played around with different microstepping and motor current values, but the noise only reduces a bit, but not significantly.

    You guys have any idea what could be wrong here?


  • administrators

    Your video sounds as though microstep interpolation is disabled. Please send M350 without parameters and verify that it reports interpolation is enabled on at least X and Y.

    When using stealthChop, the M569 V parameter and M915 H parameter determine the speed at which the driver switches over to spreadCycle. So you will need to reduce M569 V and possibly increase M915 H to continue to use stealthChop mode at printing speeds.



  • Hi dc42 and thanks for the quick reply!

    M350 Output:

    Microstepping - X:16(on), Y:16(on), Z:16(on), E:16(on)
    

    "(on)" means Interpolation is enabled or microstepping is enabled? I don't see interpolation specifically mentioned here.

    I have tried adding the V30 parameter to the M569 commands for every drive but it doesn't seem to have any effect noise wise. The video is for a test "print" at 30mm/s speed.

    About the M915 command I'm not sure. It is for stall detection, but at the moment I have no stall detection configured. You suggest I should set it up as well?


  • administrators

    Yes the M915 is for stall detection; however on the TMC5160 stall detection doesn't work in stealthChop mode, so it switches to spreadCycle mode when the speed threshold for stall detection is exceeded. The default threshold is 200 full steps per second. If you send M915 without parameters, it will report what the stall detection speeds are. These are belt speeds, so if your machine is e.g. CoreXY then they may not be the same as the X and Y speeds.

    Please send M115 to confirm that you really are running firmware 3.1.0.

    BTW we have another report of stealthChop mode not working when it should at higher speeds, and we have an investigation of this under way.



  • OK, I just confirmed Interpolation is working by temporarly changing it to I0 in M350 and the sound got even worse 😄

    Initial settings:

    M115
    FIRMWARE_NAME: RepRapFirmware for Duet 3 MB6HC FIRMWARE_VERSION: 3.1.0 ELECTRONICS: Duet 3 MB6HC v0.6 or 1.0 FIRMWARE_DATE: 2020-05-15b1 
    
    M915
    Driver 0.0: stall threshold 1, filter off, steps/sec 200 (8.0 mm/sec), coolstep 0, action: noneDriver 0.1: stall threshold 1, filter off, steps/sec 200 (16.0 mm/sec), coolstep 0, action: noneDriver 0.2: stall threshold 1, filter off, steps/sec 200 (8.0 mm/sec), coolstep 0, action: noneDriver 0.3: stall threshold 1, filter off, steps/sec 200 (16.0 mm/sec), coolstep 0, action: noneDriver 0.4: stall threshold 1, filter off, steps/sec 200 (40.0 mm/sec), coolstep 0, action: noneDriver 0.5: stall threshold 1, filter off, steps/sec 200 (16.0 mm/sec), coolstep 0, action: none
    

    I tried increasing the H parameter for the stall detection with M915:

    M915 P0.0:0.1:0.2:0.3:0.4:0.5 S3 H20000
    M915
    Driver 0.0: stall threshold 3, filter off, steps/sec 20270 (810.8 mm/sec), coolstep 0, action: noneDriver 0.1: stall threshold 3, filter off, steps/sec 20270 (1621.6 mm/sec), coolstep 0, action: noneDriver 0.2: stall threshold 3, filter off, steps/sec 20270 (810.8 mm/sec), coolstep 0, action: noneDriver 0.3: stall threshold 3, filter off, steps/sec 20270 (1621.6 mm/sec), coolstep 0, action: noneDriver 0.4: stall threshold 3, filter off, steps/sec 20270 (4054.0 mm/sec), coolstep 0, action: noneDriver 0.5: stall threshold 3, filter off, steps/sec 20270 (1621.6 mm/sec), coolstep 0, action: none
    

    But I didn't notice any change in noise


  • administrators

    @ropi said in Very loud motors:

    But I didn't notice any change in noise

    Is that with the M569 V parameter also reduced to about 30?



  • Yes, M569 V30 is set as well:

    M569 P0.5
    Drive 5 runs in reverse, active low enable, step timing fast, mode stealthChop, ccr 0x08053, toff 3, tblank 1, hstart/hend/hdec 5/0/0, pos 40, tpwmthrs 30 (125.0 mm/sec), thigh 200 (18.8 mm/sec)
    M569 P0.3
    Drive 3 runs in reverse, active low enable, step timing fast, mode stealthChop, ccr 0x08053, toff 3, tblank 1, hstart/hend/hdec 5/0/0, pos 776, tpwmthrs 30 (125.0 mm/sec), thigh 200 (18.8 mm/sec)
    M569 P0.2
    Drive 2 runs in reverse, active low enable, step timing fast, mode stealthChop, ccr 0x08053, toff 3, tblank 1, hstart/hend/hdec 5/0/0, pos 328, tpwmthrs 30 (62.5 mm/sec), thigh 200 (9.4 mm/sec)
    M569 P0.0
    Drive 0 runs in reverse, active low enable, step timing fast, mode stealthChop, ccr 0x08053, toff 3, tblank 1, hstart/hend/hdec 5/0/0, pos 328, tpwmthrs 30 (62.5 mm/sec), thigh 200 (9.4 mm/sec)
    

  • administrators

    Let me check what 'thigh' in M569 does, because the corresponding speed it reports is below the speed you are using.


  • administrators

    Yes, you need to reduce THIGH as well. It's the H parameter in M569. The conditions required for stealthChop mode to be used (in addition to being enabled) are all of the following:

    • Tstep > Tpwmthrs (set Tpwmthrs using the V parameter of M569)
    • Tstep > Thigh (set Thigh using the H parameter of M569)
    • Tstep > Tcoolthrs (set Tcoolthrs indirectly using the H parameter of M915)


  • OK so the problem was the motor mounts. It seems like they transmitted vibrations into the frame. I installed some motor dampers today and everything got much better.


Log in to reply