Duet2 wifi - blank screen on pc - ok on cellphone

  • Re: Duet 2 WiFi - Web Control Connection Issues

    I am having the following issue when connecting to duet wifi from pc chrome/firefox/opera browsers:

    Blank screen on pc browser and "WiFi reported error: incomplete write" on paneldue.

    On android chrome and opera browsers, everything is ok. Tried to rollback dwc versions and wifiserver versions. No luck.
    When rolled back to dwc 1.22.6 the page opens but it cant connect.

    F12 debug screen shows: GET about:blank net::ERR_UNKNOWN_URL_SCHEME GET about:blank net::ERR_UNKNOWN_URL_SCHEME

  • On android, every browser tested (Opera, firefox, chrome), everything is ok.
    Using latest dwc version 3.1.1 all went ok on android.
    Opening http://duetip/reprap.htm works even on my tv browser (which i dont know what it is). But keeps disconnected on pc browsers.

  • Moderator

    Can you try clearing your browser cache?

  • Hi. Tried everything regarding browser version, cache, cookies. Even tried using portable browsers.

  • Moderator

    I might try removing the entire /www folder and replacing it fresh from the zip file.

  • @Phaedrux
    I've tried that too.
    Even replaced and reformatted the sd card. Using fresh new downloaded sd card contents.

  • This is my M122 dump result:

    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.1.1 running on Duet WiFi 1.02 or later
    Board ID: 08DGM-956GU-DJMSW-6J9FA-3SD6R-TUMMG
    Used output buffers: 3 of 24 (15 max)
    === RTOS ===
    Static ram: 27980
    Dynamic ram: 94120 of which 44 recycled
    Exception stack ram used: 264
    Never used ram: 8664
    Tasks: NETWORK(ready,636) HEAT(blocked,1224) MAIN(running,1880) IDLE(ready,80)
    Owned mutexes: WiFi(NETWORK)
    === Platform ===
    Last reset 00:00:57 ago, cause: software
    Last software reset at 2020-05-23 15:19, reason: User, spinning module GCodes, available RAM 8672 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task MAIN
    Error status: 0
    MCU temperature: min 28.9, current 29.7, max 29.8
    Supply voltage: min 12.3, current 12.3, max 12.4, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2020-05-23 15:20:12
    Cache data hit count 97470607
    Slowest loop: 4.22ms; fastest: 0.13ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Storage ===
    Free file entries: 9
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest read time 2.3ms, write time 0.9ms, max retries 0
    === Move ===
    Hiccups: 0(0), FreeDm: 169, MinFreeDm: 169, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    === GCodes ===
    Segments left: 0
    Movement lock held by null
    HTTP is idle in state(s) 0
    Telnet is idle in state(s) 0
    File is idle in state(s) 0
    USB is idle in state(s) 0
    Aux is idle in state(s) 0
    Trigger is idle in state(s) 0
    Queue is idle in state(s) 0
    Daemon is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 199.67ms; fastest: 0.09ms
    Responder states: HTTP(2) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0), 0 sessions
    HTTP sessions: 2 of 8

    • WiFi -
      Network state is active
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 1
      WiFi firmware version 1.23
      WiFi MAC address 80:7d:3a:15:81:11
      WiFi Vcc 3.39, reset reason Unknown
      WiFi flash size 4194304, free heap 23408
      WiFi IP address
      WiFi signal strength -51dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0

  • Moderator

    This one may be for @chrishamm to investigate

  • When opening page on android web browsers, no errors showing on paneldue. Even when reloading pages. DWC opens on android with newer version 2.x and 1.x (http://duetip/reprap.htm). No errors at all.

  • Tried connecting on Firefox running inside a linux machine on virtualbox. Not working too.

  • Damn. Tried disabling all protection on Kaspersky Total security. Errors happened too. Tried uninstalling Kaspersky. It started working again!
    This has made me nuts. Im troubleshooting this since 10 hours ago.
    Kaspersky is the problem.
    For any still unknown reason (for me), kaspersky blocks connection between pc and duet wifi. Kaspersky was installed since a few months. Some update has made this mess.
    Thank you all! 😊

  • administrators

    @brunoap said in Duet2 wifi - blank screen on pc - ok on cellphone:


    Looks like DWC is trying to open ports 79 and 1504 on the Duet. The requests should be rejected by the WiFi module, however if they are being done concurrently with fetching the web files, then this could be causing the WiFi module to run out of concurrent connections or message buffers. That may explain the "incomplete write" message.

    I can't think why DWC would open those ports, unless it's something that's relevant when DWC is taking to a single-board computer connected to a Duet 3.

    What operating system does your PC run? Do you have anything installed on the PC that might be intercepting TCP/IP messages and adding a few of its own? Have you done a virus scan on the PC recently?

    EDIT: your response of 20:05 arrived just after I finished sending this.

  • administrators

    @brunoap, please can you connect to the Duet via USB/YAT and send M111 S1 P14 to enable WiFi debugging. Then try to connect to the Duet in your browser again. Report any messages that appear in YAT.

    This sounds related to an issue that we had in version 1.21, and in that case I was able to resolve it by increasing some buffer parameters in the WiFi firmware. That might work again in this case.

Log in to reply