Bed probing issues coords not valid



  • im just trying to get this thing dialed in.

    i had to move my home location to the centre of the bed, with my new flexplate the IR sensor was reading off the flex plate and was giving errors,

    i have zeroed down my axis movements,

    x -110 min max 110
    y-122 min max 122

    now when i execute g1 x0 y0 the print head goes directly to the middle of the print bed.

    when i set my mesh coords it saying that these coords arent valid when i run a g32, when clearly they are. IE if i command the print head to go to any of these coords it will go.

    5/25/2020, 1:38:25 AM: : Warning: Skipping grid point (90.0, -110.0) because Z probe cannot reach it
    Warning: Skipping grid point (90.0, -10.0) because Z probe cannot reach it
    5/25/2020, 1:39:25 AM: G1 X90 Y-10
    5/25/2020, 1:41:54 AM: Upload of config.g successful after 0s
    5/25/2020, 1:42:05 AM: Failed to maintain connection to 192.168.1.44: CORS request failed
    5/25/2020, 1:43:38 AM: : Warning: Skipping grid point (90.0, -110.0) because Z probe cannot reach it
    Warning: Skipping grid point (110.0, -110.0) because Z probe cannot reach it
    Warning: Skipping grid point (110.0, -90.0) because Z probe cannot reach it
    Warning: Skipping grid point (90.0, -90.0) because Z probe cannot reach it

    here is my config.g

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Mon May 11 2020 00:13:10 GMT-0600 (Mountain Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"JoehBo3D" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes forwards
    M569 P4 S1 ; physical drive 4 goes forwards
    M584 X0 Y1 Z2:4 E3 ; two Z motors connected to driver outputs Z and E1
    M671 X-160:160 Y0:0 S1 F1 ; leadscrews at left (connected to Z) and right (connected to E1) of X axis
    M208 X-110:110 Y-122:122 ; X carriage moves from -5 to 205, Y bed goes from 0 to 200
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping without interpolation
    M92 X80 Y80 Z800 E790 ; set steps per mm
    M566 X1020 Y1020 Z24 E3000 ; set maximum instantaneous speed changes (mm / min)
    M203 X6000 Y6000 Z180 E8000 ; set maximum speeds (mm / min)
    M201 X6000 Y6000 Z100 E3000 ; set accelerations (mm / s ^ 2)
    M906 X935 Y935 Z935 E935 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-110 Y-122 Z0 S0 ; set axis minima
    M208 X110 Y122 Z203 S1 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M558 P1 H3 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P600 X-24 Y-2 Z0.120 ; set Z probe trigger value, offset and trigger height
    M557 X-110:110 Y-110:110 S20 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4388 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S300 ; set temperature limit for heater 1 to 300C

    ; Fans
    M106 P0 S0 I0 F500 H1 T45 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1:1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    M501 ;

    here is my BED.g

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Mon May 11 2020 00:13:10 GMT-0600 (Mountain Daylight Time)
    G28 ; home
    G30 P0 X-110 Y0 Z-99999 ; probe near a leadscrew, half way along Y axis
    G30 P1 X60 Y0 Z-99999 S2 ; probe near a leadscrew and calibrate 2 motors
    M561 ; clear any bed transform
    G29 ; probe the bed and enable compensation

    here is my HOMEALL.g

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Mon May 11 2020 00:13:11 GMT-0600 (Mountain Daylight Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-110 Y-122 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-110 Y-122 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X0 Y0 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    thanks for looking.

    Joeh



  • I just ran into the same problem. I am trying to probe my bed. It looks like the probing is using the probe location for coordinates on the minimal side, but then uses the print head location on the maximal size, and it will skip the last probe.

    The G30 command would probe outside of the print boundaries.

    It seems like bed leveling should always use the probe location when determining where it is probing and whether it is out of bounds or not.



  • In M557 you have to put probe coordinates, not nozzle coordinates.
    For exampe, your first warning : your x max is 110 and probe offset in x is -24. That means, probe can reach max x 86. So it can not reach x 90 and gives warning.



  • @aidar ohhh i totally forgot to factor in my probe offset!

    This is my brain at 2am!

    Ill get back to you



  • @aidar i have made the adjustments with my probe taken into account and im sure ive got this correct.

    ; Z-Probe
    M558 P1 H3 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P600 x-2 Y-24 Z0.120 ; set Z probe trigger value, offset and trigger height
    M557 X-108:110 Y-98:122 S20 ; define mesh grid

    how my printer works, x-110 y-122 is the front corner of the machine the bed (y) axis moves front to back, back corner is x110 y122 and obviously 0,0 is smack in the middle of my bed.

    currently the probe is on the front side of the hotend, so if the nozzle is sitting at x -110 the probe is actually probing off of the buildtak system, so when i adjust the mesh to y-108 ( y offset is -24 infront of the hotend) it probes the buildtak just perfect.

    so now when i run g32 im still getting errors, even though the probe physically has access to all of them and can see them.

    Warning: Skipping grid point (-88.0, 102.0) because Z probe cannot reach it
    Warning: Skipping grid point (-68.0, 102.0) because Z probe cannot reach it
    Warning: Skipping grid point (-48.0, 102.0) because Z probe cannot reach it
    Warning: Skipping grid point (-28.0, 102.0) because Z probe cannot reach it
    Warning: Skipping grid point (-8.0, 102.0) because Z probe cannot reach it
    Warning: Skipping grid point (12.0, 102.0) because Z probe cannot reach it
    Warning: Skipping grid point (32.0, 102.0) because Z probe cannot reach it
    Warning: Skipping grid point (52.0, 102.0) because Z probe cannot reach it
    Warning: Skipping grid point (72.0, 102.0) because Z probe cannot reach it
    Warning: Skipping grid point (92.0, 102.0) because Z probe cannot reach it
    Warning: Skipping grid point (92.0, 122.0) because Z probe cannot reach it
    Warning: Skipping grid point (72.0, 122.0) because Z probe cannot reach it
    Warning: Skipping grid point (52.0, 122.0) because Z probe cannot reach it
    Warning: Skipping grid point (32.0, 122.0) because Z probe cannot reach it
    Warning: Skipping grid point (12.0, 122.0) because Z probe cannot reach it
    Warning: Skipping grid point (-8.0, 122.0) because Z probe cannot reach it
    Warning: Skipping grid point (-28.0, 122.0) because Z probe cannot reach it
    Warning: Skipping grid point (-48.0, 122.0) because Z probe cannot reach it
    Warning: Skipping grid point (-68.0, 122.0) because Z probe cannot reach it
    Warning: Skipping grid point (-88.0, 122.0) because Z probe cannot reach it
    Warning: Skipping grid point (-108.0, 122.0) because Z probe cannot reach it



  • got it sorted,

    instead of making adjusting the y negative position i had to adjust the positive position (at the back of the bed...) which makes no sense to me.

    ; Z-Probe
    M558 P1 H3 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P600 x-2 Y-24 Z0.120 ; set Z probe trigger value, offset and trigger height
    M557 X-108:110 Y-110:198 S100 ; define mesh grid

    all is working well with the probing movements.

    Joeh



  • @joehsmash said in Bed probing issues coords not valid:

    instead of making adjusting the y negative position i had to adjust the positive position (at the back of the bed...) which makes no sense to me.

    You got it right. Your Ymax is 122 and probe offset Y-24. That means, probe can reach Y98, not more. So yes, you had to adjust mesh area at positive side.
    And look at your last post: M557 X-108:110 Y-110:198 S100. I hope that Y 198 is typo, because it should be 98, not 198.



  • It was indeed a typo.
    thanks for your help on this one, now on to to the last issue, which i am about to post on..


Log in to reply