New LDO Motors on X & Y - now noisy



  • Hey team.....

    Since installing 2 x new Prusa STD LDO motors on X and Y the X and Y moments have become extremely noisy. The previous motors were Geetech 1.8a , and extremely quiet.

    I have tried everything , and nothing I can do quietens them down.

    1. variance current anywhere from 450 to 800
    2. Changing micro-steping to 256, with 32 and 128 in the middle

    They sound "dry" - its awful

    Build is a X=Zaribo MK3 with rails on X, Y and Z

    TIA - this i driving me potty
    Ray

    CONFIG.G below

    ; Configuration file for Duet Maestro (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.4 on Tue Dec 24 2019 01:03:43 GMT+1300 (New Zealand Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Zaribo" ; set printer name
    M918 P1 E4 F2000000 ; configure direct-connect display
    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe
    ; Network
    M552 P192.168.0.66 S1 ; enable network and set IP address
    M553 P255.255.255.0 ; set netmask
    M554 P192.168.0.6 ; set gateway
    M586 P0 S1 ; enable HTTP
    M586 P1 S1 ; enable FTP
    M586 P2 S1 ; enable Telnet

    ; Drives (Steves Settings)
    ;M584 X0 Y1 Z2:4 E3 P3 ; stepper driver mapping
    M584 X0 Y1 Z2:4 E3 P3
    M671 X-38:293 Y100:100 S10 ; Z Lead Screw Leveling probe Point Mapping
    ;M671 X30:235 Y100:100 S2 ; Z Lead Screw Leveling probe Point Mapping
    M569 P0 S0 ; Drive 0 goes reverse [ X Axis ] [ S0 = Rev / S1 = FWD ]
    M569 P1 S0 ; Drive 1 goes reverse [ Y Axis ]
    M569 P2 S0 ; Drive 2 goes reverse [ Z Axis - LT ]
    M569 P4 S0 ; Drive 4 goes reverse [ Z Axis - RT ]
    M569 P3 S1 ; Drive 3 goes Norm [ E0 ]
    M350 X16 Y16 Z16:16 E16 I1 ; Configure microstepping with interpolation
    ;M92 X1600 Y1600 Z400:400 E830 ; Set steps per mm
    M92 X100.30 Y100.250 Z400:400 E830 ; Set steps per mm
    M566 X450 Y450 Z30:30 E600 ; [ JERK Settings ] Set maximum instantaneous speed changes (mm/min)
    M201 X1000 Y1000 Z200:200 E1250 ; Set ACCELERATIONS (mm/s^2)
    M203 X6000 Y6000 Z720:720 E2000 ; Set MAX SPEEDS(mm/min)
    M906 X650 Y650 Z400:400 E600 I30 ; Set motor CURRENTS (mA) and motor idle "power saving" decrease factor as percentage [ I30=30% ]
    M84 S30 ; Set idle timeout

    ;M569 P0 S1 ; physical drive 0 goes forwards
    ;M569 P1 S1 ; physical drive 1 goes forwards
    ;M569 P2 S1 ; physical drive 2 goes forwards
    ;M569 P3 S1 ; physical drive 3 goes backwards
    ;M584 X0 Y1 Z2 E3 ; set drive mapping
    ;M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    ;M92 X80.00 Y80.00 Z400.00 E415.00 ; set steps per mm
    ;M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    ;M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    ;M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    ;M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    ;M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X245 Y210 Z200 S0 ; set axis maxima

    ; Z-Probe
    M558 P9 H5 F350 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-20 Y-35 Z4.552 ; set Z probe trigger value, offset and trigger height
    M557 X-5:260 Y-10:210 S35 ; define mesh grid
    ;M557 X5:250 Y0:210 S40 ; define mesh grid
    ;---------------------------
    ; Heaters
    ;---------------------------

    ; *** Bed H0
    M305 P0 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C

    ; *** Extruder / HotEnd H1
    M301 H1 P10.1, I0.326, D39.2 B0 ; H1 Hotend E0 use PID || Last Auto-tune results 260C --> [ P11.0, I0.391, D41.0 | P10.1, I0.326, D39.2 ]
    M305 P1 T100000 B4725 R2200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S275 ; Set temperature limit for heater 1 to 275C
    ;M307 H1 A254.4 C144.6 D4.4 B0 ; Saves this models parameters || B0 = Use PID / B1 = Bang Bang || PWM 1.00 || No more M301 4 H1 after this

    ; Heaters

    ;M305 P1 T102000 B4388 R4700 ; set thermistor + ADC parameters for heater 1
    ;M143 H1 S240 ; set temperature limit for heater 1 to 280C

    ; Fans
    ;M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ;M106 P1 H100:101 T50:55 L0.3
    M106 P2 S1 I0 F500 H-1 ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss


  • administrators

    What VIN voltage are you using, and what's the specification of the new motors?



  • @dc42
    Hi,

    The VIN Voltage is 24V

    the motors are the default Prusa X and Y motor, unfortunately the part number on the motors does not yield any results for specification.

    It's gone from a really nice quiet printer to now I cannot run it whilst the kids are in bed

    stepper-motor-x-axis.jpg

    Cheers

    Ray


  • Moderator

    @Kiwi3D There was this thread recently about noisy LDO Prusa motors: https://forum.duet3d.com/topic/15121/is-it-normal-for-motors-to-vibrate-and-hiss-at-standstill

    Ian


Log in to reply