Network issues¿?



  • ok forum

    out of the blue, im having connection issues... it just drops and i can't reach the board.

    C:\Users\EveryUser>ping 192.168.50.102 -t
    
    Pinging 192.168.50.102 with 32 bytes of data:
    Reply from 192.168.50.100: Destination host unreachable.
    Reply from 192.168.50.100: Destination host unreachable.
    
    Ping statistics for 192.168.50.102:
        Packets: Sent = 2, Received = 2, Lost = 0 (0% loss),
    Control-C
    ^C
    C:\Users\EveryUser>
    

    ...102 is the IP of the board..

    toggling the wifi module (M552 s0, then s1) doesn't work... I've restarted the router... nothing.

    Besides restarting the board (it is printing so no go), what would be your suggestions?

    this is my M122

    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.1.1 running on Duet WiFi 1.0 or 1.01
    Board ID: 08DAM-999TL-MQ4S4-6JKF2-3S86M-94G3Z
    Used output buffers: 1 of 24 (12 max)
    === RTOS ===
    Static ram: 27980
    Dynamic ram: 93852 of which 68 recycled
    Exception stack ram used: 640
    Never used ram: 8532
    Tasks: NETWORK(ready,268) HEAT(blocked,1224) MAIN(running,1868) IDLE(ready,80)
    Owned mutexes: WiFi(NETWORK)
    === Platform ===
    Last reset 00:51:57 ago, cause: software
    Last software reset at 2020-05-29 19:36, reason: User, spinning module GCodes, available RAM 8604 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task MAIN
    Error status: 0
    MCU temperature: min 36.9, current 37.7, max 38.1
    Supply voltage: min 11.8, cur=== Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.1.1 running on Duet WiFi 1.0 or 1.01
    Board ID: 08DAM-999TL-MQ4S4-6JKF2-3S86M-94G3Z
    Used output buffers: 1 of 24 (12 max)
    === RTOS ===
    Static ram: 27980
    Dynamic ram: 93852 of which 68 recycled
    Exception stack ram used: 640
    Never used ram: 8532
    Tasks: NETWORK(ready,268) HEAT(blocked,1224) MAIN(running,1820) IDLE(ready,80)
    Owned mutexes:
    === Platform ===
    Last reset 01:08:09 ago, cause: software
    Last software reset at 2020-05-29 19:36, reason: User, spinning module GCodes, available RAM 8604 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task MAIN
    Error status: 0
    MCU temperature: min 37.1, current 37.9, max 38.2
    Supply voltage: min 11.8, current 12.1, max 12.2, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: ok, SG min/max 0/284
    Driver 1: ok, SG min/max 0/314
    Driver 2: standstill, SG min/max 0/26
    Driver 3: ok, SG min/max 0/0
    Driver 4: standstill, SG min/max not available
    Date/time: 2020-05-29 20:45:05
    Cache data hit count 4294967295
    Slowest loop: 2.80ms; fastest: 0.14ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Storage ===
    Free file entries: 9
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest read time 0.9ms, write time 0.0ms, max retries 0
    === Move ===
    Hiccups: 0(0), FreeDm: 157, MinFreeDm: 124, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 89976, completed moves: 89936, StepErrors: 0, LaErrors: 0, Underruns: 0, 0  CDDA state: 3
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0  CDDA state: -1
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    Heater 0 is on, I-accum = 0.1
    Heater 1 is on, I-accum = 0.5
    === GCodes ===
    Segments left: 1
    Movement lock held by null
    HTTP is idle in state(s) 0
    Telnet is idle in state(s) 0
    File is doing "G1 X178.283 Y149.528 E0.02004" in state(s) 0
    USB is ready with "m122" in state(s) 0
    Aux is idle in state(s) 0
    Trigger is idle in state(s) 0
    Queue is idle in state(s) 0
    Daemon is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 199.81ms; fastest: 0.09ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0), 0 sessions
    HTTP sessions: 0 of 8
    - WiFi -
    Network state is active
    WiFi module is connected to access point 
    Failed messages: pending 0, notready 0, noresp 4
    WiFi firmware version 1.23
    WiFi MAC address 60:01:94:09:aa:4b
    WiFi Vcc 3.36, reset reason Software watchdog
    WiFi flash size 4194304, free heap 24984
    WiFi IP address 192.168.50.102
    WiFi signal strength -60dBm, reconnections 0, sleep mode modem
    Socket states: 0 0 0 0 0 0 0 0
    ok
    rent 12.0, max 12.2, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: ok, SG min/max 0/312
    Driver 1: ok, SG min/max 0/332
    Driver 2: standstill, SG min/max 0/29
    Driver 3: sta[Warning: Maximal number of bytes per line exceeded! Check the EOL (end-of-line) settings or increase the limit in the advanced terminal settings.]
    

    Notice that i have 60 dBm.. which is supposed to be good.


  • Moderator

    I assume you have a paneldue or USB console to send commands without the network connection?

    What do you get as a response to sending M552 by itself?
    How about just M587 by itself?



  • @Phaedrux said in Network issues¿?:

    ?
    long usb cable and yat.. (for now)

    m552
    WiFi module is connected to access point Valhalla, IP address 192.168.50.12<LF>ok<LF>
    m587
    Remembered networks:<LF>Valhalla IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0<LF>ok<LF>
    

  • Moderator

    Looks like it has ip 12 and not 102



  • i just released the ip on the router.

    It was forced to 102...


  • Moderator

    So it's working now?


Log in to reply